Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Optimus

Ctrl+Alt shoot-strafe

Recommended Posts

Something that's bugging me. I think from time to time I was encountering a source port or maybe another old Doom-clone, where I realized the player shoots while he strafes, when I press Right-Alt to strafe I also waste ammo (and wake up monsters).

Now I found this again in Chocolate-Doom and was furious, and then also ran the original Doom on Dosbox and it did that again. I thought it can't be since I always was playing Doom with Alt only for strafe and Ctrl for shoot. Ran the setup.exe to check controls, when I select Alt for strafe it registers as Ctrl. The right buttons of course. Now to play with the left buttons would not be my liking, I am not used to that.

Of course I don't have problems in many modern ports. But I just wondering, is it my keyboard? I thought in the past it was a newbies idea who wants to shoot strafe at the same time and can't handle separate. Because I remember I encountered it before and frowned. But now I see my keyboard (a mechanical keyboard) or something else is making the problem at least for Chocolate Doom and Doom in dosbox.

Is there a solution? What is it? Maybe I'll try to use another keyboard and see.

Share this post


Link to post

I have noticed this too, and not only in Doom and related source port, but I think in Quake too.

I have two "Alt" keys in my keyboard. One is on the left, "Alt", the other on the right, "Alt Gr". I used this one to strafe when I played doom.exe. Now I shot&strafe at the same moment.

Share this post


Link to post

I switched to another keyboard and it does it again.
I will also try to see what happens in original Doom on an old DOS machine I have just right here.

Share this post


Link to post

I have encountered this again and wonder if it's a common issue that many people have?

It doesn't seem to be a keyboard issue, I don't have this issue in ZDoom or GZDoom but have it in many other ports as Chocolate-Doom.

Thankfully, I remembered this as I compiled Chocolate-Doom to try something else, so I could also check the keyboard code and see what does it do differently than say Zdoom.

Share this post


Link to post

WASD + Mouse:

W = move forward
S = move backward

A/D = Strafe left/right respectively

Aim and shoot/use with the mouse...

 

 

 

 

Problem solved

Share this post


Link to post
Posted (edited)

I've never had this problem, however something similar with g/zdoom is when I press fire doomguy decides to change weapon on the odd occasion, which I find amusing tbf.

Share this post


Link to post
1 hour ago, Liberation said:

I've never had this problem, however something similar with g/zdoom is when I press fire doomguy decides to change weapon on the odd occasion, which I find amusing tbf.

This is why you use your damn safety. No wonder the marines got wiped out if their best of the best doesn't know proper trigger discipline.

Share this post


Link to post
Posted (edited)

I finally found the issue!

 

I have noticed similar things happening in few other games too (playing Killing Time on GOG) that when I tried to map the Right-Alt, it came as Left-Control. In KT however this worked fine. Today, I run KT and strafe wasn't worked. I tried to remap and it shows properly as Right-Alt and then it works.

 

Anyway, to cut it short, it's the language settings. I am living in UK, have a UK keyboard, and have three input languages, United States (this was added automatically by default), UK and Greek. Switching to US input will fix the issue. Anything else will register Right-Alt wrongly. Good to know.

 

Another funny thing, as my input switch combination is Alt+Shift, and I have Shift for run, while I was playing, I will switch languages in the background again and get the same problem too. So, as I was testing Chocolate Doom when in US input, and it finally worked fine, after few minutes I got the bug again (I even was trying to type a save name and I was in greek so I got nothing =). So, the solution is to change language-switching key combination in Windows to something else.

 

ZDoom/GZDoom doesn't have this problem.

 

p.s. I sure do play Doom with WAXD and mouse these days, but I was testing some old doom ports and was too lazy to set up mouse (or maybe it freaks me out in software rendering especially with shearing or even weirds me when you can't control up/down view but slide around) and wanted to retry playing like the old times.

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×