Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Mordeth

[SOLVED ACS bug] ACS_ExecuteAlways means Never

Recommended Posts

Consider an Imp with the following addition in his pain frame state:

TROO H 4 StartScriptNamed("Blah",2,103,0)
Script Blah looks something like this:
script "Blah" ( int a, int b ) {
    ...
    ACS_ExecuteAlways( 100, 0, c, d );
    ACS_Execute( 200, 0, c, d );
}
Imagine script 100 and 200 just having a print() at the top, then terminating. The Imp does activate script "Blah", but "Blah" fails to run the script in ACS_ExecuteAlways but works as intended for ACS_Execute.

I've tried this with a few of the latest builds but that didn't seem to make a difference.

Edit: see this thread for example wad.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×