Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Mr.Ash

Needing help with an odd graphical glitch in GZDoom

Recommended Posts

Hi there. I have been plagued by this issue for a few days and I've tried everything that I could think of to fix it... but to no avail.

The issue I'm having only happens in 1920x1080 full screen.

Taking screenshots via prtsc and posting into paint only shows me the console.

Taking in game screenshots with the command spits out a screenshot that looks absolutely fine... Seriously nothing wrong.

I've completely uninstalled my drivers and re-installed them. When that didn't work I rolled back to previous drivers that I know worked fine with GZDoom. After that didn't work I completely removed GZDoom and downloaded several different dev builds and official releases.... to no avail. I took a short video with my phone to show the issue. I apologize for the random ringtone at the end of it, my wife's phone went off... If you guys could help me that would be amazing.

My honeymoon phase with the new Doom is now over and I want to get back to ripping and tearing the old fashioned way. Any help would be appreciated.

Video: https://youtu.be/NqJTsAuxc2Q

Share this post


Link to post

That's actually the next step I'm working on. I posted this here a little early wondering if it could be something else. I'm downloading Doom3 BFG edition (terrible I know but it has WADS) So as soon as it's done I'm going to try those. The WADs I'm using now came from a friend of mine so I'll let you know as soon as I try.

Share this post


Link to post

The printscreen function in Windows doesn't take a snapshot of the exact frame displayed in the GPU frame buffer, it takes whatever is in the DWM at that time. However, OpenGL, especially in exclusive fullscreen, doesn't normally touch the DWM at all, and thus the system printscreen function doesn't snap it, sans whatever was last drawn in the DWM. This rule can seem inconsistent because some OpenGL games run in borderless fullscreen (for example), so DWM is still used as an intermediate buffer.

Either run the game in windowed mode, use built in screenshot functions, or an external application designed to capture OpenGL framebuffers (like FRAPS). Shadowplay can also capture it incidentally in desktop mode, as it works on a much higher level than DWM.

Share this post


Link to post
Mr.Ash said:

Alright. Entirely different PWADs and it still happens. I seriously do not understand this....


We're gonna need some specs first. Card? OS? Driver version?


Also, when you press PrtSc/Print Screen, you're not taking a picture of the screen as you see it. All the OS sees is what it draws, or what is called by programs for it to draw. This is alright for some things like browsers and word processors, but anything using 3D graphics (which usually bypass the OS these days) is another kettle of fish entirely. I know it sounds absurd, but you're not going to get any viable screenshots that way.

Share this post


Link to post

My problem has NOTHING to do with screenshots. Everything to do with a graphical error. I can get a screenshot if I want. I uploaded a video just for this purpose. I'm trying to get the graphical error to STOP.

CPU: AMD FX 8800P APU
Graphics : Linked AMD R7
Ram:8GB
OS: Windows 10

EDIT: http://imgur.com/a/Kk0sV

Share this post


Link to post
Mr.Ash said:

My problem has NOTHING to do with screenshots. Everything to do with a graphical error. I can get a screenshot if I want. I uploaded a video just for this purpose. I'm trying to get the graphical error to STOP.

Ah, my bad. You confused me with your tangent about printscreen and it made it sound like that was your actual problem. Also the fact that the other person asked if it was somehow the WAD, which is maddeningly impossible.

The immediate question is if it's related to any recent changes GZDoom have made. Compare the latest devbuild to the latest stable release.

Share this post


Link to post

I would be inclined to think along with you here, but unfortunately even downloading d00msd@y just for shits and giggles.... same exact issue. L4D2 works fine, so other games are okay. Seems to be isolated to Doom source ports in full screen. This is incredibly bewildering.

EDIT: Downloaded fraps and tried to take some screenshots/videos... they all came out black.

Share this post


Link to post

Actually, you isolated the problem to OpenGL. L4D2 is a Direct3D game. Try another GL game like Doom3BFG, or Doom4 if you have it. If it's OpenGL, this is likely a driver fault and you'll need to contact AMD about it, not this forum.

Share this post


Link to post

Just tried BFG Edition... sure enough. Issue is there as well. This is going to be fun. Thank you for your help though. I'll be heading over to bug people at AMD.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×