Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Blastfrog

Audio concerns

Recommended Posts

I'm thinking that the sounds ought to be resampled to 11025 upon build (keep the high quality ones intact in the source), and that music ought to be converted to .mus upon build (keeping the .mid format versions intact in the source).

The reason for this is that some engines like BFG Edition play the sounds at a fixed source rate, completely ignoring the rate defined by the file. Ports like Doom 95 don't play MIDIs, only MUS.

I'm not sure, but there might be a few other odd engines out there with the same quirks. If there is, please let me know.

Share this post


Link to post

What deeply perverse soul is going to want to play Freedoom in BFG edition

Share this post


Link to post

The only "audio concern" besides a few midis being too loud is that some sounds are missing. I don't see a reason to make every sound 11025 when higher values are supported by the original exe.

Share this post


Link to post

I believe the SFX is too loud.

Seriously, I keep my sound option set around 20-25%, just so I can at least hear the music.
I don't experience the same problem in Doom though.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×