Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[SOLVED BUG] 436 -> 440 3DMidTex/Portal elevator broken

Recommended Posts

The Vaporware demo showcases an elevator that can traverse between portals, by having copies of the elevator in the different portals that match heights. This still works with the latest DRDTeam builds. You can do the same with 3DMidTex lines, attached to a moving control sector and copied for the portals it travels in between. A player standing on top of these moving 3DMidTex lines can travel between portals this way.

At least, up to build 436 (march 15th, 2016). Starting with build 439 (march 17th) the portal itself stopped being interactive, so as the 3DMidTex 'platform' sinks to the lower portal the player keeps standing on air. From build 440 (march 19th) up until the latest build the entire 3DMidTex 'platform' also becomes impassible to the player, even if he should be able to pass.

Share this post

Link to post

As is seen here, there was a lot of activity regarding 3DMidTexes at the time.

My guess would be that this broke the thing for the March 19th build. I'm less sure about what broke the March 17th build, but I'm guessing this commit broke it.

Share this post

Link to post

I've fixed it. Fortunately there was nothing wrong with the two commits mentioned by Altazimuth, but they certainly were the cause. They just weren't completely done, so I added now the code to handle your case.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now