Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
invictius

Why does zdaemon and gzdoom look so different to me?

Recommended Posts

Short answer: because they are both differentish.
Zdaemon uses the software renderer. GZDoom uses OpenGL as its default renderer, so more effects are present.

Share this post


Link to post

You need to set vid_renderer to 0 and gamma to 666 to make GZdoom look properly.

Share this post


Link to post

I've heard some people mention that ZDaemon looks washed out after playing a lot of Doom in OGL, especially when using gamma correction.

Offtopic, but I have no idea how so many OpenGL users can just let the sprites clip into the ground.. The first thing I have to do when using an OGL port is adjust the sprite clipping and billboarding!

Share this post


Link to post
Doomkid said:

Offtopic, but I have no idea how so many OpenGL users can just let the sprites clip into the ground.. The first thing I have to do when using an OGL port is adjust the sprite clipping and billboarding!


I thought most ogl users adjusted the sprite clipping and billboarding. to me if you have the default settings of gzdoom (i don't know zandronum's default settings) it looks VERY bad or if you have gamma correction on.

Share this post


Link to post

It's been years since I touched the port, but to my memory ZDaemon's default gamma setting was higher than normal for some weird reason. Make sure your gamma is set to 1.0 for a 1:1 comparison.

Also, unless you're running relatively recent GZDoom releases, OpenGL can't quite replicate software lighting falloff very well (which causes things closer to your vision to appear brighter), making your surroundings look "flatter" than they should.

Share this post


Link to post

I like the way the dead player sprite looks in software mode in Zdaemon compared to how it looks in Gzdoom hardware mode.
It probably has to do with sprite clipping in hardware render?

Share this post


Link to post

Yes, there is a sprite clipping option in GZDoom, it has Always, Smart etc.

Not sure what is the default.

Share this post


Link to post

In GZDoom:

Options->Display Options->OpenGL Options->Preferences->Sector Light Mode

It's probably set to Standard. Change it to Software.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×