Eureka 1.21 Released

I seem to have found a couple of bugs while making my map :/ First off values of 0 are automatically deleted for unknown action type arguments which has caught me out several times lately when I am trying to use a feature which eureka itself doesn't technically support like dynamic lights for example. And I found a node/sector builder bug which causes a crash, basically I am building a sloped cave leading to an underground geothermal plant right, and I found that the curved slope I was trying to create was too steep and so has a jagged drop off on the inside of the corner so i tried to remedy this by making a triangle sector there with a less aggressive slope to ease the transition, well when I went to draw it I got an error that said "bug detected: tried to create 0 length line" followed immediately by a crash, luckily I had saved about a minute beforehand... I had the grid size at 32 btw, trying to draw it again after putting the grid to something smaller like 8 worked fine so it might be something with that

 

Edit: oh, and the secret area tag is mislabeled when using hexen format, it is labeled as 9 when it is actually 1024. This needs to be fixed too

Edited by therektafire

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now