Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Jonko

PrBoom+ Bad Textures

Recommended Posts

Sorry that I've come to this community and asked so many questions. I think it's a little selfish of me since these threads really don't benefit anyone except myself, so hopefully this will be my last one for a while.
I've installed PrBoom+ and found that a lot of levels have inappropriate texturing, as seen below.







Is there any way to fix this?

Share this post


Link to post

What happened? Did you tamper with the IWAD's TEXTURE lumps? Nothing like that has ever happened to me.

Share this post


Link to post

Are you trying to play doom.wad while also using doom2.wad? You shouldn't combine them.

Share this post


Link to post

Are you trying to play doom.wad while also using doom2.wad? You shouldn't combine them.

Yeah, that might be it. Not willingly though. I just put my doom and doom2 wad in the same folder and when I set the game to Doom, it shows the Doom 2 title screen but only lets me pick Doom episodes.
After removing doom2.wad from the folder, the launcher shows Doom II grayed out, but when I launch Doom it still shows the Doom 2 title screen.

Share this post


Link to post

You should set up batch files in that case (if you don't want to use the cmdline everytime), something like this:

prboom-plus -iwad doom.wad
prboom-plus -iwad doom2.wad
Frankly, I'm surprised you managed to load them together. I don't remember them loading together at all for me. I'm even more surprised that it DID take both WADs. That's not normal behaviour. Typically, it selects the first IWAD it finds in the directory and loads only that IWAD.

Share this post


Link to post
Jonko said:

Where do I enter this code?

Open up Notepad.
Type in this (assuming doom.wad is in the same folder as the exe)

prboom-plus -iwad doom.wad
Save as doom.bat

Create a new file.
Type in this (assuming doom2.wad is in the same folder as the exe)
prboom-plus -iwad doom2.wad
Save as doom2.bat

Put the new bat files in your prboom+ folder, and run whichever one you want.

Now would be a good time to learn command line parameters.

Share this post


Link to post

Sounds like DOOM.WAD loaded as an IWAD and DOOM2.WAD loaded as a PWAD.

Share this post


Link to post

It is surprising that prboom loaded them both, like it or not heh.

Nvl, like Voros suggested and if you're going to create batch files, you may need to show file extensions to do so, so they can be changed from .txt to .bat.
In Windows, you'll need to goto view>folder options>view tab, and uncheck "hide extensions for known file types".

This however sort of depends on the Windows version. In Windows 10 you may just be able to check the box "file name extensions" from view panel.

Cheers

Share this post


Link to post
Voros said:

Open up Notepad.
Type in this (assuming doom.wad is in the same folder as the exe)

Unfortunately the wads aren't in the same folder as the exe; I'm using a Mac. Wads are located in ~/Library/Application Support/PrBoom-Plus, along with my saves and prboom-plus.cfg. I created the .bat files (indeed, with the extension .bat) and moved them to that folder, but nothing changed.

Share this post


Link to post

Oh damn, Mac? I haven't touched that in years, nor do I have access to one. Maybe someone here can give you the equivalent to a batch files. Mac has a Unix-like structure, so maybe some Linux users can help you, along with Mac users?

Share this post


Link to post
Voros said:

Oh damn, Mac? I haven't touched that in years, nor do I have access to one. Maybe someone here can give you the equivalent to a batch files. Mac has a Unix-like structure, so maybe some Linux users can help you, along with Mac users?

I really hope so. It's too bad that being so new to the community, I don't know any Mac/Linux users. Hopefully they will happen across this thread.

Share this post


Link to post

I managed to reproduce the problem with the following command (assuming the WADs are in the same directory as the EXE, otherwise you can add pathing to the WADs for similar results):

prboom-plus.exe -iwad doom.wad -file doom2.wad
Are you sure this problem is specific to PrBoom+? I would confirm that the IWAD itself isn't corrupt by testing against something else like Chocolate Doom or via DOSBox. ZDoom has some means to correct this, as a similar attempt at WAD-loading produced no texture problems (EDIT: not quite NO problems... the switches in the E3M4 screenshot are still misaligned). You could also analyze the IWAD files themselves by comparing their values to those on the Doom Wiki (checking filesize is often satisfactory).

Another possibility, specific to PrBoom+, is that there are some predefined files getting in the way. In prboom-plus.cfg there is a "Files" section that contains wadfile and dehfile definitions. If they're not blank ("") try removing any values between the double-quotes and see if that solves the problem.

Share this post


Link to post

I've just resolved the problem, and I feel quite dumb now. Under Wad Options in the launcher I added path names to both my Doom and Doom II wads. I really don't know why I assumed you had to manually specify where the wads are located, but there you go. Although now I'm not getting any sound at all, so it's just one thing after another.
Thanks everyone for your help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×