Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SynthGal

Vanilla stairs and lift problems (also hello)

Recommended Posts

Hello, I'm making my very first Doom map ever (as well as my first post, so if I make any glaring rule breaks, I wholeheartedly apologise. I haven't used a forum in years!), and I'm trying to get some switch-triggered stairs to work. I can get them to sorta work with a walkover linedef, but even then it doesn't quite raise the stairs correctly and the switch doesn't work at all. The partially working walkover only does its thing if everything involved is tagged as 0, tagging it and the stairs as anything else screw it up.

I'm also trying to get a downwards lift to trigger via walkover that permanently stays down, because I want this ledge to lower and reveal a huge monster closet. This isn't working at all.

I've searched the forums for the past hour or so trying to find answers since I didn't wanna be a burden with dumb newbie questions, but either I'm not phrasing my search terms right or I'm simply not seeing the answers right in front of me. I tried a few youtube tutorials as well, but no dice.

http://imgur.com/a/rw69B
I know it all looks like trash, I figured I'd get the basic layout and technical bits working before I made it look pretty. Thanks a bunch, and sorry for the dumb questions.

Share this post


Link to post

Zdoom has all sorts of funky, generic ways to do things, so I cant tell you exactly what names to look for, but a bit of general info here might help.

For starters, stuff working from a non-direct action with a tag of 0 is a zdoom thing, a common error of new mappers, and something to generally avoid, as nothing differentiates other sectors and even things in zdoom with tags of 0. That said, I believe zDoom just makes them apply locally, same as a direct action, which would appear to be the case as the sector on the back side of the triggering line raises.

Hopefully you've learned this much, but just in case, it helps to know what the letters and numbers mean when picking actions, though zDoom has many generic actions, so some of these may not apply:

D-Direct
W-Walk over
S-Switch
G-Gunfire

R-Repeatable forever
1-Activates only the first time it's triggered.

When using the switch, you should be using a different triggering mechanism than when using the walk-over linedef.

Moving on to stairs: perhaps zDoom is different on this, but iirc you only tag the first "stair" and the rest is determined by linedef facing. I don't usually use stair actions, though, so I could be missing a detail.

The monster closet: when you say a downwards lift, do you specifically want the lift sound to play? If not, then it's just a simple floor lower, likely to lowest adjacent floor. Speed can be chosen; the only differences between a lift and moving floor is ultimately the sound that plays and a lift's ability to raise back to it's previous height. With this, once again remember to choose the correct triggering mechanism and tags.

Share this post


Link to post

Actually, I haven't learned that because I've been using Doom Builder 2 and the generalized actions tab. Also I'm using GZdoom so I have no idea if that makes a difference.

I know that I shouldn't be tagging stuff with 0 for indirect actions, but it's the only way it even partially works. The youtube tutorials were very helpful in understanding linedef facing, so the steps at least stop where I want them. I tried setting the switch and the first step to tag 1, but I still come to the issue of the switch not working, but still being silent when I interact with it (as described in the imgur captions) so it's clearly registering as a switchy linedef, but just not triggering anything or changing textures. I reread the remote actions vanilla thread in the tutorials board, but that didn't seem to help.

I didn't realise there was "floor lower" actions since apparently I'm completely blind and dumb because it didn't even occur to me that the action I want is in there. Monster closet works perfectly now, thanks!

Oh, crap. I figured out what I did wrong. I tagged the first linedef of the stairs, not the first sector.

All good now.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×