Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ranhcase

Boom compatible source ports(?)

Recommended Posts

(this is surely a dumb question but anyway). I would like to know what are the Boom compatible source ports, as i'm making a map in the Boom format, and i would like to play test it with something other than GZDoom

Share this post


Link to post

It's easier to list the (notable) ones that can't support Boom-compatible maps: Chocolate Doom (deliberately vanilla) and Crispy Doom (deliberately limit-removing-only).

Probably the best source port to use for playtesting Boom-compatible maps is prboom-plus, specifying either the '-complevel 9' command line argument to specify Boom 2.02 compatibility, or '-complevel 11' to specify MBF compatiblity if you're using the "sky transfer" special linedefs.

Share this post


Link to post

This should be a good list; that said if you want to do Boom-compatibility testing, the gold standard is to use PrBoom+ with complevel 9.

Share this post


Link to post
Gez said:

This should be a good list; that said if you want to do Boom-compatibility testing, the gold standard is to use PrBoom+ with complevel 9.


Thanks

Share this post


Link to post
grommile said:

It's easier to list the (notable) ones that can't support Boom-compatible maps

There are other notable exceptions such as JDoom (Doomsday) which doesn't yet have complete Boom compatibility.

Share this post


Link to post
Da Werecat said:

3DGE?

As far as I can see, it still doesn't support generalized actions, which is partial compatibility at best.



Yes, but it's in the works, as I understand it.

Share this post


Link to post
grommile said:

Probably the best source port to use for playtesting Boom-compatible maps is prboom-plus, specifying either the '-complevel 9' command line argument to specify Boom 2.02 compatibility, or '-complevel 11' to specify MBF compatiblity if you're using the "sky transfer" special linedefs.

Sky transfers work in prboom-plus even with -complevel 9 iirc.

Share this post


Link to post

I think they work with every complevel, since it's just a cosmetic feature, and being picky about it wouldn't really benefit anyone.

Unless that's changed recently.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×