Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
bonnie

Can't replace doomguy sprites in prboom+

Recommended Posts

I tried posting this to the miscellaneous editing question thread but got no response, so I'll just copy and paste my question here. Thanks.

"Hello friends. I'm trying to replace the doomguy sprites with various images of alex jones in slade for use with prboom+.

So far, they work fine with gzdoom, but no luck with prboom+. The regular doomguy sprites appear instead. Just to be sure I wasn't disabled, I made a copy of the doom 2 iwad and replaced the same sprites there, and it worked.

I've had no issues replacing sprites for things like obstacles as well as replacing textures (so far), so I'm surprised that this is giving me trouble. I can't post any attachments but I can assure you that I'm using the correct names and they have been converted to doom format or whatever and they're real small and in the right spot and stuff."

Share this post


Link to post
FuzzballFox said:

Did you put in SS_Start and SS_End ? markers in the wad? Newer ports can ignore them iirc


yes

Share this post


Link to post
Voros said:

But did you put them in the correct order?


I didn't know that mattered so I had organized them. But then I made a new wad and put them all in the original order and checked if that worked and it still didn't.

Share this post


Link to post

i have not given up, i have made an alex jones chainsaw that fires bfg shots every tic and it worked fine

surely there must be something specific i was supposed to do for doomguy's sprites that I didn't do

Share this post


Link to post

Share your wad. Maybe the problem can be resolved by looking through the wad file's content.

Share this post


Link to post
bonnie said:

I didn't think I was allowed to.

Of course you were, it's your wad. Posting a wad is seriously the best way to get help. I thought you didn't share it before because you didn't want to show your work in progress to anybody yet (some people think that way).

The "STF*" graphics are not sprites, they're HUD graphics, so just put them outside of any markers, not within the sprite markers. When you say "doomguy sprites", people imagine the "PLAY*" sprites (doomguy's body as seen by other players in multiplayer), not the "STF*" HUD graphics (doomguy's face as seen by the player himself on his own HUD), that's why nobody understood the problem until now.

Share this post


Link to post
scifista42 said:

Of course you were, it's your wad. Posting a wad is seriously the best way to get help.


I didn't think I could because it says i'm not allowed to post attachments in the bottom lefthand corner and I thought that applied to links too aww man i'm a dummy :(

scifista42 said:

When you say "doomguy sprites", people imagine the "PLAY*" sprites (doomguy's body as seen by other players in multiplayer)

what kinda nerd replaces actual player sprites what the heck

otherwise thank you greatly, you have helped alex jones fight the info war

Share this post


Link to post
bonnie said:

what kinda nerd replaces actual player sprites what the heck


You made me LOL, thank you.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×