Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Summer Deep

Loading games in prboom-plus, command line

Recommended Posts

I always load Doom games by double-clicking on the source port's exe icon, or by dragging and dropping a pwad over it, or by using ZDL where loading order is critical. However I've become curious about doing it via the command line, and have been attempting to use prboom-plus.

 

From everything I've read, something like "prboom-plus -iwad -file" is required (without the speech marks, of course!).

 

So after putting the required iwad and pwad into my prboom-plus, directory, I tried: "prboom-plus -iwad Doom2.wad -file scythe2.wad" 

 

Result: FAILURE, with the message "'prboom-plus' is not recognized as an internal or external command, operable program or batch file."

 

I then tried varying things, for example replacing "prboom-plus" with "prboom-plus.exe", then with just "prboom", but always with no result except for a similar message as before in the command prompt window.

 

Just when I'd almost given up on the whole thing, I tried with Zdoom, and it worked perfectly first time.......

 

Can anyone please give me an indication as to where I've been going wrong with prboom, and perhaps indicate the exact form of words which should have been used in the example I gave above?

 

Oh, and trying with glboom-plus gave the same result as with prboom-plus, by the way.

Share this post


Link to post

Hi there! This message means that Windows doesn't know where to find the prboom-plus executable. There are a few ways to solve this.

  1. Add the prboom directory to your PATH environment variable. You can google how to do this -- it's not hard. The PATH variable is a list of the places your computer automatically searches for executable files.
  2. Explicitly give it the path each time. So it would look something like "C:\path\to\prboom-plus.exe -iwad Doom2.wad -file scythe2.wad" -- you might also have to give it the path to the IWAD and PWAD files, or else edit some configuration file to tell it where to look for them.
  3. Enter the directory before running prboom-plus. Just enter the command "cd C:\path\to", followed by "prboom-plus.exe -iwad Doom2.wad -file scythe2.wad". Again, you might have to specify the location of WAD files.

As a linux ZDoomer, I'm quite familiar with the command-line interface for ZDoom and linux systems, but less familiar with prboom and Windows. Hopefully this helps!

Share this post


Link to post

^^ Thanks, I'll try some of that out later after I've had a few hours' sleep! The issue of 'paths' had occurred to me, but I thought it wouldn't be a problem, as I prefaced my efforts with "cd C:\users\summer deep\downloads\prboom-plus" (folder name previously edited from 'prboom-plus 2.5.1.4-win32).

Share this post


Link to post
10 minutes ago, Summer Deep said:

cd C:\users\summer deep\downloads\prboom-plus

^^ That's a problem -- your path has a space in it. You need to put quotes around it, in the command line, like this:

 

cd "C:\users\summer deep\downloads/prboom-plus"

 

Spaces in filenames is something Windows ought to abolish, IMO. Unix systems do not allow it.

Share this post


Link to post

Also, the slashes in the path should all be forward slashes (/), not backward slashes (\).

Share this post


Link to post

One way to confirm the correct path is to attempt to auto-complete the executable. Start by typing "prboom-plus" and press the TAB key until an ".exe" is appended: if this never happens, you're not in the desired folder.

 

Another technique I often use is to navigate via Windows Explorer to the folder you want, Shift+right-click some open space in the folder window (being careful not to select a file), and choose "Open command window here". Bam! Exactly where you need to be. I use this when I know the path is obnoxious to type out.

Share this post


Link to post

FWIW there's a windows registry setting for the "Open command window here"  option that allows just a right-click to show it in the menu.

Share this post


Link to post
20 hours ago, 42PercentHealth said:

Spaces in filenames is something Windows ought to abolish, IMO. Unix systems do not allow it.

Erm. I'm not sure where you get your information from, but Unix systems allow spaces in file names just fine too.

11 hours ago, jeff-d said:

FWIW there's a windows registry setting for the "Open command window here"  option that allows just a right-click to show it in the menu.

Not much of a setting, but you can get the job done anyhow:

 

Open Notepad, and copy-paste this into the window:


Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Directory\shell\CommandPrompt]
@="&Command Prompt Here"

[HKEY_CLASSES_ROOT\Directory\shell\CommandPrompt\command]
@=hex(2):22,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,\
  00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,63,00,\
  6d,00,64,00,2e,00,65,00,78,00,65,00,22,00,20,00,2f,00,6b,00,20,00,63,00,64,\
  00,20,00,2f,00,64,00,20,00,22,00,25,00,4c,00,22,00,00,00

 

Save it as a file named like "CommandPromptHere.reg" (use quote marks in the Save As dialog so you don't accidentally get a *.reg.txt), and then double click the file to add it to the registry. Now, you should have a "Command Prompt Here" on the right-click menu of any folder :)

Share this post


Link to post

Well I've finally got this thing to work, after hours of banging my head against a brick wall, so to speak. It turns out that my PrBoom-plus folder was inside another PrBoom-plus folder (not sure why, maybe this is the way it was unpacked from the zip file?).

 

The correct path is C:\users\summer deep\downloads\prboom-plus\prboom-plus-2.5.1.4.

 

The reason I got ZDoom to work so easily from the command line is presumably because it was in just one folder....

 

I'm very grateful for the information and opinions supplied by all contributors to this thread. I've learned a fair bit about the navigation process in Windows, and the 'Open command window here' short cut looks very useful indeed.

Share this post


Link to post
3 hours ago, chungy said:

Erm. I'm not sure where you get your information from, but Unix systems allow spaces in file names just fine too.

By golly, you're right. Back in my Windows days, I was taught to avoid it so much that I guess I thought it was a Unix compatibility issue. I guess it's just a user convenience issue.

 

I've learned my new thing for the day! :-)

Share this post


Link to post

@Summer Deepyou can also use batch (.bat) files to more quickly play/replay WADs with PrBoom.

it starts with creating a .txt file (i.e. with Notepad)

type your normal cmd line into the text file, e.g.

 

prboom-plus -iwad doom2.wad -file scythe2.wad -complevel 2 -skill 4 -warp 1

 

this would take you to map01, with UV difficulty of scythe 2. the complevel isnt *required* but it sets the compatibility settings for the game which can affect stuff like switches and linedefs. most WADs will be 2 (doom2) 3(doom.wad) 4(tnt.wad & plutonia.wad) or 9 (for many 'boom' PWADs)

 

the final step is to rename the .txt file as .bat (you need to have file extensions turned on to see this)

now that .bat file basically behaves like a specialised .exe to open up PrBoom with whatever settings are inside it. i rename them (e.g. "Alien Vendetta Playthrough.bat") and keep some around for different WADs and PWADs so i dont have to enter cmdlines every time i play

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×