Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SWAGART

Chocolate Doom wont play custom wads

Recommended Posts

So I've been trying to get my chocolate doom to run a map I map that was really basic just a big square to test if it will work. Chocolate Doom runs fine as long as i execute it as:

 

pi@raspberrypi: ~/Doom $ chocolate-doom -iwad DOOM1.WAD

 

How would i go about playing like a custom made level from doom builder?

 

Any and all help is appreciated!!

Share this post


Link to post

I ended up figuring it out. The iwad I was using was shareware, so, doesn't work. ran with DOOM.WAD and everything is running nice now. 

Share this post


Link to post
On 4/19/2017 at 7:52 PM, Graf Zahl said:

Like in any other port: By using '-file wadname.wad'.

 

Not quite. Modern style PWAD loading is actually done via the -merge command, plain -file replicates vanilla's extremely limited behavior.

Share this post


Link to post

-merge is mainly useful when loading a wad that contains custom sprites. If the wad doesn't contain custom sprites, -file typically works just fine. If the wad contains custom sprites and uses a DEHACKED trick that makes vanilla accept them, -file also works fine as long as the DEHACKED is loaded via -deh or -dehlump.

Share this post


Link to post

WAD_merging_capability

 

-file might be all that you need, on the othe hand you might end up needing to use -aa instead.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×