Hello. I wanted to begin learning some Doom 64 mapping but it seems that tutorials for this particular installment are non existent.

I just wanted to ask if following a doom builder 2 tutorial might be worth it or if it is a waste of time in this context. There seem to be some differences, mainly the sector lighting controls, which i haven't figured out yet.

By the way, I got the editor form the official DoomEX site, by Kaiser.

Thanks in advance.

Share this post


Link to post

From my very limited experience it's mostly the same but has it's own scripting system kinda like ACS but is a little more structured. For example, you can't do macro 1 then macro 3, there must be a macro 2 even if it's an empty macro. My advice to learning it is to open the stock Doom 64 maps up in the builder and make modified versions and change stuff around to see what happens.

1 person likes this

Share this post


Link to post

ACS, Macros, things i need to look into, i guess, since i'm at a bit of a loss. 

Opening the specific maps in the editor sounds like a good idea but i don't know how to do that :(
 

Opening the Doom64 wad file doesn't yield a map list. Any thoughts?

Share this post


Link to post

The maps are actually their own WADs inside the DOOM64.WAD. You will need to extract them out using SLADE and then open those WADs in the editor.

1 person likes this

Share this post


Link to post

You just reminded me... I've been really wanting to try out Doom 64 mapping... thanks!

1 person likes this

Share this post


Link to post

Just one more question: if/when i have questions regarding doom 64 mapping specifically, is there an ideal place where i should ask them?

 

Share this post


Link to post

Right here is fine, it could be your own Doom 64 editing questions thread. I know I'll keep checking it when I get notified of a new post.

Share this post


Link to post

Oh, ok, thanks a lot. 

 

One problem i ran into yesterday had to do with changing a sector's brightness using ctrl+mouse wheel. Every time i entered visual mode or tested the map no changes in brightness were visible, even though the brightness does change in the top view mode.

Sorry for asking such basic questions. Cheers.

Share this post


Link to post

The editor has a button (can't remember if the default shortcut is B or L) which toggles full brightness in visual mode (and only in the editor's visual mode, no effect onto the map itself).

1 person likes this

Share this post


Link to post

I think that is some kind of weird behavior in Doom Builder 64. There is no way to change brightness via sector properties, only light color (which acts as sector brightness/light level in Doom 64). The only way I see to actually change brightness of the sector is to use brightness mode, but even then it only shows the changes in 2D mode or classic mode. Going into visual mode shows the brightness as it was before (default of 192). To get full brightness you'll need to set the sector lighting to be white on each property (upper wall, lower wall, floor, ceiling, and thing). Changing light intensity acts as changing brightness both in-game and in visual mode, but strangely enough not in 2D mode.

1 person likes this

Share this post


Link to post

Sorry for not checking in for a while. Yes, i was getting really frustrated because i had tried a bit of doom builder 2 last year and i had no such problems with brightness. I haven't made any progress in the past few days because of work but i want to get back to it soon. Thanks for the help so far :)

Share this post


Link to post

Hello

 

Just wanted to share something weird that happened to me today. I was trying to make a door just a while ago, and when i tested the map and opened it this appeared.

That wall/texture was also operable and when it slid up it was dragging the corridor behind it upwards as well, as if the sector behind the door was also part of it. Also strange was the fact that if i opened the door from the opposite side, it worked as intended.

I suspect that it might have to do with "lower unpegged" settings or whatever, i still need to check  more closely. Sorry about low brightness.

 

Capture.PNG.3d406a061bb24d557ebddb9bea14543a.PNG

Edited by Chlorophylia
Part of the text i wrote was scattered beside and under the picture i uploaded and i wanted to improve how the post looked.

Posted (edited)

Share this post


Link to post
On 2017-5-6 at 5:14 PM, Chlorophylia said:

Hello

 

Just wanted to share something weird that happened to me today. I was trying to make a door just a while ago, and when i tested the map and opened it this appeared.

That wall/texture was also operable and when it slid up it was dragging the corridor behind it upwards as well, as if the sector behind the door was also part of it. Also strange was the fact that if i opened the door from the opposite side, it worked as intended.

I suspect that it might have to do with "lower unpegged" settings or whatever, i still need to check  more closely. Sorry about low brightness.

 

Capture.PNG.3d406a061bb24d557ebddb9bea14543a.PNG

I Believe thats the texture for Missing Texture/No Texture

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now