Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
cacomonkey

How do I select my windows default MIDI device in GZDoom 3.1.0??

Recommended Posts

The newest version of GZDoom-3-1-0a-x64 has a custom soundfont that it defaults to.  I use BASSMIDI to configure my own sf2 soundfont (Timbres of Heaven) for my Windows default MIDI device.  How do I force GZDoom 3.1.0a to use it instead of the custom one?

Share this post


Link to post

From what I heard you cannot select a 32 bit MIDI driver from a 64 bit application. Best check what devices are available in the menu. If BASSMIDI can be used it will be listed.

 

 

Share this post


Link to post
1 hour ago, Graf Zahl said:

From what I heard you cannot select a 32 bit MIDI driver from a 64 bit application. Best check what devices are available in the menu. If BASSMIDI can be used it will be listed.

 

 

Okay, thanks for the info.  I just switched to a 64-bit MIDI driver program (VirtualMIDISynth) and now GZDoom 3.1.0 recognizes it in the Sound Options, allowing me to select my own soundfonts.

Share this post


Link to post
On 6/9/2017 at 0:01 PM, cacomonkey said:

The newest version of GZDoom-3-1-0a-x64 has a custom soundfont that it defaults to.  I use BASSMIDI to configure my own sf2 soundfont (Timbres of Heaven) for my Windows default MIDI device.  How do I force GZDoom 3.1.0a to use it instead of the custom one?

 

You should simply be able to select bassmidi in GZdoom's sound options.  It doesn't matter if bassmidi is 32 or 64-bit.

 

Bassmidi also allows you to set itself as the default MIDI device in Windows, too.

Share this post


Link to post
5 minutes ago, Master O said:

 

You should simply be able to select bassmidi in GZdoom's sound options.  It doesn't matter if bassmidi is 32 or 64-bit.

 

Bassmidi also allows you to set itself as the default MIDI device in Windows, too.

 

It's not listed among the devices in Sound Options in my installation of GZDoom 3.1 x64 for some reason.

Share this post


Link to post
7 minutes ago, cacomonkey said:

 

It's not listed among the devices in Sound Options in my installation of GZDoom 3.1 x64 for some reason.

 

It shows up for me in 64-bit GZdoom 3.1., so the problem must be on your end.

Share this post


Link to post
10 minutes ago, Master O said:

 

It shows up for me in 64-bit GZdoom 3.1., so the problem must be on your end.

 

Hmm.  I can't get it to show up in any GZDoom version, even old builds, 32-bit nor 64-bit.  I'm going to try reinstalling it.

 

Edited To Add:  This did the trick.  BassMIDI now shows up in the Sound Options in GZDoom 3.1.  Thanks for the post.  I prefer BASSMIDI over all the other MIDI drivers.

Edited by cacomonkey

Share this post


Link to post
2 hours ago, VGA said:

But VirtualMIDISynth uses the BASSMIDI driver :D

I don't like the way VirtualMIDISynth automatically opens and leaves its icon in my Windows toolbar whenever I run GZdoom configured with it and play a wad.  Prefer a more transparent "behind the scenes" type of MIDI interface like BASSMIDI.  MIDI drivers should be heard and not seen ;)

Share this post


Link to post

You are right, I don't like the icon either. I will ask the author about it.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×