Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

USDF Stopped Working, Then Lost All My Work

Recommended Posts

I'm seriously about to burn down the city over this.


I wrote TONS of dialogue trees in Zdoom USDF format, and it was all working just fine yesterday. I try adding new stuff in the same format and testing it, and suddenly it stopped working, and even removing the new dialogues wouldn't fix the problem.


And THEN....I saved and closed without realizing I hadn't restored all the shit I deleted, including EVERYTHING i finished yesterday.


EDIT: FORTUNATELY I had a deleted backup from yesterdays version in the recycle bin, so i lost everything from today but not yesterday. Still infuriating that I gotta type it all up again.


But now I'm still not sure why this crap isn't working today. First thing in the decorate file is this:


namespace = "ZDoom";
include = "SCRIPT80";


It worked just fine yesterday. Today it keeps telling me "expected {, got =" regarding the namespace line when it wasn't a problem before. Can't even run the map unless I remove all this crap.


EDIT2: I guess I had to make it all in a regular text file instead of a decorate file. I was under the impression it was decorate's version of USDF, but I guess not. Seems like the problem solved itself. Fortunately.

Edited by Impie

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now