Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
nicolas monti

Chocolate.exe asking for Iwad textures from pwads

Recommended Posts

Well, as the tittle says I cannot test my pwads with the -file command because it crashes asking for iwad patches and textures, I'm already using the -iwad command so I don't know what's happening.

Share this post


Link to post

I think the TEXTURE1 lump in your wad doesn't contain all iwad switches, which is not allowed. The problem is that it actually replaces the TEXTURE1 lump from doom2.wad instead of combining them like ZDoom does I guess.

Share this post


Link to post
6 minutes ago, Searcher said:

is that the full path to the iwad?  Is it finding and Loading the iwad?

when I don't use the -file command it loads the iwad with no conflict, it's like it asks for the original patches and textures in every fileI load ignoring they are already in the iwad. the pwad has new textures so I don't know if that is causing this but it shouldn't.

 

Share this post


Link to post
19 minutes ago, Memfis said:

I think the TEXTURE1 lump in your wad doesn't contain all iwad switches, which is not allowed. The problem is that it actually replaces the TEXTURE1 lump from doom2.wad instead of combining them like ZDoom does I guess.

Nice, I'll make new dummy textures named after the SW1-SW2 series and see what happens.

Share this post


Link to post

I see it is your own project. In SLADE when you create a new Texture lump I believe it asks if you want to import all of Doom 2 in it.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×