• 0

Fences and gate problems...

Question

Im trying to do gates in my hell map, but they stop at a certain height and idk how to change the height.  I included a picture of what I mean.  Any advice is appreciated.  Thanks all!  BTW, source port is ZDOOM and i am using doombuilder 2

Screenshot_Doom_20170914_112903.png

Edited by AleksB

Share this post


Link to post

11 answers to this question

  • 0

I assume you are using ZDoom (Hexen format) since you can set this directly in UDMF.

 

Give the linedef a special 121 (Line_SetIdentification) and set the flag to 16 (Wrap Mid Texture).

It will show in-game but not in preview.

Share this post


Link to post
  • 0
1 minute ago, Kappes Buur said:

I assume you are using ZDoom (Hexen format) since you can set this directly in UDMF.

 

Give the linedef a special 121 (Line_SetIdentification) and set the flag to 16 (Wrap Mid Texture).

It will show in-game but not in preview.

Sorry Im not sure if I understand correctly.  How would you do that?

Share this post


Link to post
  • 0
2 minutes ago, Kappes Buur said:

I assume you are using ZDoom (Hexen format) since you can set this directly in UDMF.

 

Give the linedef a special 121 (Line_SetIdentification) and set the flag to 16 (Wrap Mid Texture).

It will show in-game but not in preview.

And yes, it Is in Hexen format

Share this post


Link to post
  • 0
30 minutes ago, Kappes Buur said:

Give the linedef a special 121 (Line_SetIdentification) and set the flag to 16 (Wrap Mid Texture).

It will show in-game but not in preview.

I don't think that's what he means or wants to accomplish.

 

Based on the picture, the gate is sinking into the floor.

 

If you want a gap between the midtexture and the upper wall, simply change the brightness behind the gate to at least 1 lower. So if the brightness is 150, change it behind the gates to 149 or 151.

 

If you do not want a gap, try setting the linedef to lower unpegged. That should bring the bottom of the gate to the floor and the top of the gate will be cut off.

 

The actual reason the gate is doing that is because in software mode (ZDoom), midtextures will do that. In hardware mode (like GZDoom) it will automatically clip as far as I know. If you want it to clip without changing brightness, in UDMF you can select clip mid texture and it should do it for you. You can also add ClipMidTextures to MAPINFO to do it universally.

Share this post


Link to post
  • 0
1 minute ago, Nevander said:

I don't think that's what he means or wants to accomplish.

 

Based on the picture, the gate is sinking into the floor.

 

If you want a gap between the midtexture and the upper wall, simply change the brightness behind the gate to at least 1 lower. So if the brightness is 150, change it behind the gates to 149 or 151.

 

If you do not want a gap, try setting the linedef to lower unpegged. That should bring the bottom of the gate to the floor and the top of the gate will be cut off.

 

The actual reason the gate is doing that is because in software mode (ZDoom), midtextures will do that. In hardware mode (like GZDoom) it will automatically clip as far as I know. If you want it to clip without changing brightness, in UDMF you can select clip mid texture and it should do it for you. You can also add ClipMidTextures to MAPINFO to do it universally.

What Im trying to do is have the gates touch the ceiling and floor with no gap at all.  In the pictures here, I didnt have to do any of that, I just applied the mid textures and they clipped to the ceiling and floor without me having to change anything before.  So I guess my question is why wont it do it in my other room?  And how Do I fix it ofcourse lol

Screenshot_Doom_20170914_125342.png

Screenshot_Doom_20170914_125351.png

Share this post


Link to post
  • 0

Here is the map so far, I know there are prolly bugs nd what not, but ive only been working on this for like 3 hours, but hopefully this will help

Devils Cut.zip

Share this post


Link to post
  • 0
11 minutes ago, Nevander said:

I don't think that's what he means or wants to accomplish.

 

Based on the picture, the gate is sinking into the floor.

 

If you want a gap between the midtexture and the upper wall, simply change the brightness behind the gate to at least 1 lower. So if the brightness is 150, change it behind the gates to 149 or 151.

 

If you do not want a gap, try setting the linedef to lower unpegged. That should bring the bottom of the gate to the floor and the top of the gate will be cut off.

 

The actual reason the gate is doing that is because in software mode (ZDoom), midtextures will do that. In hardware mode (like GZDoom) it will automatically clip as far as I know. If you want it to clip without changing brightness, in UDMF you can select clip mid texture and it should do it for you. You can also add ClipMidTextures to MAPINFO to do it universally.

And also, I did try the lower unpegged but that only did it for the backside which makes no sense to me since I selected it from the front side

Share this post


Link to post
  • 0
12 minutes ago, AleksB said:

What Im trying to do is have the gates touch the ceiling and floor with no gap at all.  In the pictures here, I didnt have to do any of that, I just applied the mid textures and they clipped to the ceiling and floor without me having to change anything before.  So I guess my question is why wont it do it in my other room?  And how Do I fix it ofcourse lol

This is because of the sector's height. That spot where it worked right away is because the sector is 128 tall. For the other room, you will need to set the linedef to lower unpegged (and upper if you want the brick texture to line up too). If you are in UDMF, you could adjust the alignment manually without needing to set any unpegging.

 

 

4 minutes ago, AleksB said:

And also, I did try the lower unpegged but that only did it for the backside which makes no sense to me since I selected it from the front side

That's odd. It should work for both sides since unpegging is linedef based, not sidedef based.

Edited by Nevander

Share this post


Link to post
  • 0
6 minutes ago, Nevander said:

This is because of the sector's height. That spot where it worked right away is because the sector is 128 tall. For the other room, you will need to set the linedef to lower unpegged (and upper if you want the brick texture to line up too). If you are in UDMF, you could adjust the alignment manually without needing to set any unpegging.

So the ceiling height can only be at 128 for gates and fences to work?

Share this post


Link to post
  • 0
1 minute ago, AleksB said:

So the ceiling height can only be at 128 for gates and fences to work?

No, it can be any height. But, for it to fit right away without adjustment the sector height needs to be 128. The gate texture is 128 tall, so it will automatically fit. Other sectors that are higher will need adjustment OR some clever geometry work to circumvent the need to adjust. For example, you could draw a thin sector in front of that wall, and lower it down to 128 height. Now it will work like the other place.

Share this post


Link to post
  • 0
1 minute ago, Nevander said:

No, it can be any height. But, for it to fit right away without adjustment the sector height needs to be 128. The gate texture is 128 tall, so it will automatically fit. Other sectors that are higher will need adjustment OR some clever geometry work to circumvent the need to adjust. For example, you could draw a thin sector in front of that wall, and lower it down to 128 height. Now it will work like the other place.

Well I fixed it now.  Man that was a pain in the ass lol.  Thanks everyone for all of your help!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now