Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Kapanyo

GZDoom crashes when loading custom model

Recommended Posts

I made my own model and texture in Blender, followed this tutorial to convert it to .md3 (the tutorial example converts to .md2) and it shows up in GZDoom Builder, but if I try to load the map (or, if I just load the .PK3 and summon it in the console), GZDoom crashes.

Pa7HHnn.png

Here's what the .PK3 looks like in Slade.

 

Models folder

 

Models/lantern

 

lantern1.png
lantern1.md3

 

MODELDEF lump

 

Model Lantern

{

Path "Models/lantern"
Model 0 "lantern1.md3"
Skin 0 "lantern1.png"
scale 5 5 5
frameindex LANT A 0 0

}

 

DECORATE lump

 

Actor Lantern 4167

{
States
{
Spawn:
LANT A -1
stop
}
}

 

TEXTURES lump

 

sprite LANTA0, 1, 1 { Patch TNT1A0, 0, 0 }

Share this post


Link to post

Update: tried literally copy pasting the code from the tutorial (that means my lamppost is known as "Mercedes") and even tried going through the converting process again but to .md2 like in the tutorial, nothing.

Share this post


Link to post

In Blender, it's only around 200 faces or something like that. However, I wasn't aware there was a polygon limit for models.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×