Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Ermi

DOOM2 (UDMF) - 3d/Portal Bug report

Recommended Posts

Hi, im not sure if it has been mentioned before but i think ive encountered a issue with portals when placed in contact with 3d models.

Here is a picture demonstrating the issue, i have 2 line portals exactly the same, one within the 3d door and another away both leading to the same place.

Currently im in room 1 in the picture shown below looking into room 2.

bug.png.d4b97ce219f40ea697749479cb70d38a.png

 

the portal still works as you would expect until your looking in from room 2 in to room 1.

its taken the model from room 1 and placed it in room 2 that has nothing in it.


bug2.png.2f0b35c805c18c45dea9adef6a16fbd7.png

 

here is a overview

bug3.png.278a2d7a20df74acdcbe2dfe8cd3285d.png

 

here is a link to the zip file  DOWNLOAD

for the record im using both the latest gzdoom and gzdoom builder

 

Edited by Ermin

Share this post


Link to post

We need to see more of the map, or maybe even upload the whole thing so we can figure out what is going on. I only see one room in your overview.

 

Edit: Nevermind. I blindly didn't notice the obvious download link.

Share this post


Link to post

Is this a pk7? If not, do I simply load all 4 wads to play it, and in what order? Hmm, maybe I'm not the best one to check this out. I tried a portal once, but discovered that portals don't work in Zandronum. I look forward to the day that they do.

Share this post


Link to post

simply drag the zip archive on to the gzdoom launcher. everything should run correctly.
Doom2 is required

Share this post


Link to post

after some more testing i figured it was not the 3d models that was causing the problem.
It turns out it was the line set infront of the portal line that was the culprit, It seems like the portal disappear when the line infront is set to impassible/blocking.
removing the line, disconnecting it or changing it to double sided seems to fix the issue.

Share this post


Link to post

On one hand, I'm sorry that you had to figure it out on your own, but on the other hand, I'm glad that you could!

Share this post


Link to post

thanks.
However there is still a issue with the 3d models i forgot to mention. When the 3d model does come in contact with a portal, the entire model is copied to the other portal. So rather than seeing the obstructed model through the portal, you actually see the entire thing. its kinder hard to explain unless you see it...
buggggg.png.2a0c00bc89faf260fe4476cb683b7230.png
The box model behind the door is actualy a model in a different room thats in contact with the portal. There is actualy nothing but the portal behind the door im looking at in this picture which can be a real issue when your crafting the entire level as a 3d mesh lol
This i think has to do with the way THINGS work in combination with portals and models in general with gzdoom.

Share this post


Link to post

My only suggestion is to try a 1-unit gap between the model and the portal. If you don't want an open gap even that short, put an old-fashioned 1-unit-long Doom wall there.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×