GZDoom Darkness issues.

So, frankly, darkness in GZDoom looks messed up. I have attached 2 screenshots. 1 is from GZDoom, the weird one, and one is from QZDoom, which is the dark one that you see less in. Please help me.

Screenshot_Doom_20171120_163224.png

Screenshot_Doom_20171120_163258.png

Share this post


Link to post
1 minute ago, Litrivin said:

Increase Ambient Light Level, its cvar is named gl_light_ambient. It seems this cvar was recently dropped though.

Well that sucks since I have been working on a GZDoom map on and off for a couple of months and I started designing it around dark sector light mode... might need to change that if this is the case...

Share this post


Link to post

If you are really designing it around GZDoom with its OpenGL features and using Dark as default sector light mode, the first thing you need to do is force that light mode through MAPINFO to ensure nobody will diverge in brightness when playing your map, second is that if you really want dark rooms but with very limited vision never use 0 light, 80 should do fine since everything below 60 light is almost pure black.

1 person likes this

Share this post


Link to post

Ok I will keep that in mind :) Although I noticed when I made a 3D bridge in one of the rooms in the map I needed to make the control sector 0 because there are dynamic lights directly above and around the bridge (since it is in a large lit room) and the bridge doesn't occlude the light above properly making it way brighter under there than it should be :/ Even with the darkest sector settings possible it's still a little bit brighter than what I would like but at least it's much more reasonable...

Share this post


Link to post

The ambient light level setting was removed because especially in 'dark' mode it rendered the lowest light levels essentially useless, everything below 90 was essentially the same, except for absolute 0.

 

 

1 person likes this

Share this post


Link to post

The only real problemI've ever noticed with the GZDoom engine is when playing in Windowed mode, in that utilizing gamma correctoin also maked the entire screen brighter, not just brigtenening things up in-game.

 

Also, picking up the Light Amp Visor (Or using IDBEHOLDL) results in an awful green tint which I'm similarly unsure on how to fix.

Share this post


Link to post

I do remember the PSX TC was (ab)using that cvar, setting it to 1 and making everything ultradark. While the real game in a real console is relatively dark, isn’t that dark...

 

1 hour ago, Traysandor said:

awful green tint

 

Just disable the Enhanced Nightvision Effect, cvar is gl_enhanced_nightvision.

Share this post


Link to post

Uh "gl_enhanced_nightvision 0" in console I guess?

Edited by therektafire

Share this post


Link to post

@therektafire This worked perfectly thank you so much!

Share this post


Link to post

After knowing what to look for, I took a browse through the options, and found Enhanced Nightvision buried within one of the GZDoom menus and disabled it.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now