Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

FIXED - Error: Unable to open file for writing.

Recommended Posts

So, I'm just getting back into Doom mapping, and downgrading from Half-Life 2 mapping is... weird... Because of that, I'm expecting a lot of history to repeat itself since the last time I've even used Doom Builder. One of those things may be an error I constantly get in SLADE 3. This would happen to be an error message stating "Error: unable to open file for writing" whenever I try to save my WAD. The only thing I'm adding right now is a MIDI of Metallica - Orion because why not? I'm not sure what the error is, but if anybody has any solutions I could try to fix this problem or to find out what's wrong, please tell as soon as possible.


Strangely, this problem's fixed itself. Nothing to do now but to close up shop.

Edited by Whiskey

Share this post

Link to post

Having installed Slade3.1.2.b5 and the appropriate Runtimes in a folder specific to Slade3, you should have no problem with installing the midi file.


If your map is for MAP01, simply drag and drop the midi file into your opened map and rename the file to D_RUNNIN, the name of the original music for MAP01. And save, as in the video.








If you make the map for another mapslot then name according to https://doomwiki.org/wiki/Doom_II_music

Share this post

Link to post
On 12/16/2017 at 0:57 AM, Whiskey said:

"Error: unable to open file for writing"

This error suggests one of the following issues:

  • This file is open in another program, like a different wad/map editor, or even opened by your source port itself.
  • You have a permission issue. The folder the file is in, or the file itself doesn't allow modification. This is unlikely. But, sometimes, editors delete the original file, and then write the modified version of the file. So, maybe the wad file permissions don't allow deleting.
  • More likely is that the editor writes temporary files in a folder created for that purpose. In Windows, sometimes that folder is deep down from the root, like C:\Users\(your account name)\Local Files\Temp, or something. These folders are used by a lot of different programs, and sometimes they have unusual permissions applied to them. A lot of times, the editor allows the user to define which temporary folder it uses. If so, it may help to create a new folder and configure the program to use that folder.

You said that your problem went away, which is good. My guess is that one of the above situations was happening, and was corrected, without you knowing what fixed it. If it happens again, consider the above possibilities, and, if you figure it out, please post what fixed it.


Good luck!

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this