Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • 0
SLADEfix

Sky in a WAD with custom textures does not show up

Question

Please Note: This is my first time using the forums as a member, so please don't make fun of me because I am not sure where does this topic should belong to and also I'm not a native speaker.

 

The problem is that I've been making this map a couple days ago on Doom Builder 2 with MLCETEX's custom textures, which probably is the source of these errors, but I don't know why.

 

Attempting to load the map on ZDoom results in a failure, and the "bad textures folder" message. Zandronum (Brutal Doom enabled) opens the map almost fine, even though it says "Unknown texture X" countless times at its log, the textures I used are ok, but the sky appears as a black screen, as you see here.

 

Now before you may ask, sky textures work just fine on maps without MLCETEX.wad's textures as a resource.

 

I don't know much about WAD editing (started this week), using SLADE 3, if there is a problem in the map's .wad, please tell me.

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 1

The TEXTURE1/PNAMES lumps of the texture pack are based on Doom 2 IWAD's TEXTURE1/PNAMES lumps. As a result, the texture pack needs to be used with the Doom 2 IWAD. You are using it with Doom 1 IWAD. You can fix this by creating a new wad, copying Doom 1 IWAD's TEXTURE1/PNAMES lumps into it, then copy-pasting only the custom textures from within the texture pack's TEXTURE1 into the new TEXTURE1.

Share this post


Link to post
  • 0
41 minutes ago, scifista42 said:

The TEXTURE1/PNAMES lumps of the texture pack are based on Doom 2 IWAD's TEXTURE1/PNAMES lumps. As a result, the texture pack needs to be used with the Doom 2 IWAD. You are using it with Doom 1 IWAD. You can fix this by creating a new wad, copying Doom 1 IWAD's TEXTURE1/PNAMES lumps into it, then copy-pasting only the custom textures from within the texture pack's TEXTURE1 into the new TEXTURE1.

http://prntscr.com/htfe37

Thank you! Works with any sky now. For now on, I will pay attention to the texture pack's description. Sorry, lol.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×