Why is infighting broken in cl-1/Current PRBoom+ mode?

I recently tried recording a casual demo in cl-1 and noticed that monster infighting was very different from other modes. Namely, monsters wouldn't infight after taking a hit and continue attacking me. For instance, it took multiple Hell Knight shots to get a Cyber to stop attacking me, without me shooting him first. I believe cl-1 takes into account gameplay options from the menu in PRBoom+, so are there any settings there to flip on/off to make it more normal?

Edited by Spectre01
Clarification

Share this post


Link to post

LOL. To be a little more helpful, here is the menu in question:

 

fEE1NR6.png

 

This is in options->setup->enemies.

1 person likes this

Share this post


Link to post

Well, that was some bad word choice on my part. Clarified the OP post. Monsters would infight, but only after multiple attacks from other enemies. For instance, a Cyber getting mauled by Hell Knights would still prioritize attacking me after killing one, and ignoring the rest scratching him for a few seconds. And that is without me shooting him first. And my enemies menu looks the same as above.

Edited by Spectre01

Share this post


Link to post

That might be "Monsters don't give up pursuit of targets" (Options - Setup - Doom Compatibility).

 

But wouldn't it be simpler to use a proper complevel? A lot of these settings options are hangovers from MBF, and unless you're playing a map designed for MBF (hardly any are), then there is little reason not to use the original behaviour (i.e. Doom or Boom depending on the map type).

 

Edited by Grazza
2 people like this

Share this post


Link to post

@Grazza Thanks, that solved the problem! The short, heh, answer is I don't like playing with shorttics; and there is no option for -longtics in -cl9 currently, aside from that branch release with voice support. Considering I'm not an avid Boom speedrunner, I don't feel like getting used to a mouse input type I don't enjoy for the odd occasion I decide to make a casual Boom UV-Max. With -cl-1, I can record something for Boom with an input type that I like.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now