Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
PeterMoro

GZDoom Builder hi-def visual mode?

Recommended Posts

I've switched from DoomBuilder to GZDoom builder and it's a step up but there's one thing that really bugs me - visual mode isn't the same hi-def quality as Doom Builder : (

 

Anyone know a way to change this, a plugin perhaps?

 

Thanx

Share this post


Link to post
Posted (edited)

Thanks for the reply! The first screenshot is Doombuilder, the 2nd is GZDoom builder. As you can see GZdb is a little blurrier and not as clear, especially when looking at details. Not such a big deal but not so great when you build maps all the time it gets real noticeable and frustrating. I thought maybe there's an easy fix? GZdb is a much lower def than DB. Actually these screenshots don't really do my point justice, but...oh well.

Screenshot (9).png

Screenshot (10).png

Share this post


Link to post

Have you tried Doom Builder X? It's same as Doom Builder 2, but with bugfixes and some added new features. 

Share this post


Link to post

Yes! and it's great but I prefer the features of GZDoom builder, the only thing that bugs me is the resolution in visual mode. I think I'll just have to get over it.  

Share this post


Link to post

Ah.......you have the visual mode with a bilinear/trilinear filter. I think that you can disable that in the options.

Share this post


Link to post

Thanks for the screenshot, had trouble finding it exactly.

 

Well i changed the settings and sadly it didn't seem to make much difference.

 

First shot is Doombuilder. 

 

I copied the setting to your screenshot.

 

Maybe this is as high a def as GZDoom builder goes?

Screenshot (11).png

Screenshot (12).png

Share this post


Link to post

You can try ask it in zdoom forum or discord about it. Maybe they could provide small update on it and this small problem would begone. Well, I use gzdoom builder two years already and I notice this now, in this thread, heh. 

Share this post


Link to post

LOL thanx. I guess it's really noticeable to me because i switch between DB and GZDB often. I'll ask the folks at Zdoom forum. 

Share this post


Link to post
34 minutes ago, Ke-Sula said:

As you can see GZdb is a little blurrier and not as clear

because of texture filtering, maybe?

 

I use GZDB, it shows pixels as it should, without blurring them. 'cause I turned filtering off.

Share this post


Link to post

This is so strange, my GZDB has the nice crispy pixel look rather than the blurry look. I thought about taking a screenshot but my settings are identical to leodoom's.

Share this post


Link to post

SOLVED!! It was the antisotropic filtering, it was set to 16x and i changed it to none. Now GZDB is crisp and clear like DB (first screenshot).

 

Whew! Thanx for your input everyone. Happy mapping days ahead : )

Screenshot (13).png

Screenshot (16).png

Share this post


Link to post
39 minutes ago, Ke-Sula said:

SOLVED!! It was the antisotropic filtering, it was set to 16x and i changed it to none. Now GZDB is crisp and clear like DB (first screenshot).

This cannot be right. The screenshots clearly show the enabled bilinear filter, that's not what the anisotropic filter does. In the shots you posted you'd probably barely see the effect of the anisotropic filter.

 

https://en.wikipedia.org/wiki/Bilinear_filtering

https://en.wikipedia.org/wiki/Anisotropic_filtering

Share this post


Link to post

??? Well i don't know the details but that's what made the difference. Not perfectly sure what antisotropic filtering does but when i reduced it to zero the graphics became as crisp as DB. I double-checked that that was the problem before i posted the screen shots. Wasn't any of the other available settings. 

 

Share this post


Link to post
Posted (edited)
On 1/2/2018 at 4:54 AM, boris said:

This cannot be right. The screenshots clearly show the enabled bilinear filter, that's not what the anisotropic filter does. In the shots you posted you'd probably barely see the effect of the anisotropic filter.

 

https://en.wikipedia.org/wiki/Bilinear_filtering

https://en.wikipedia.org/wiki/Anisotropic_filtering

I was having the same issue, turning Anisotropic filtering to 0 fixed it for me as well.  Now, to figure out why mine doesn't higlight surfaces when I have the cursor on them...

Share this post


Link to post

You can toggle highlighting by pressing the (by default) H key.

Share this post


Link to post

I wanted to add that turning off filtering on GZDoom Builder, at least on my machine, did not switch the 3D view to nearest neighbor rendering. I much prefer this because it's difficult to do precision texture alignment when it's a blurry mess.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×