Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
GoatLord

Can't properly run latest PRBoom, QzDoom, Zandorum, GzDoom

Recommended Posts

Posted (edited)

Keep in mind I have downloaded the latest build of each of these source ports, from their official sites.

 

Zandorum runs, but the ketchup v5 Smooth Doom patch that's designed for Zandorum won't work. PRBoom runs with a severely distorted palette. QZdoom loads only a black screen in hardware, in addition to not initiating the sound, even though other source ports do. GZdoom also loads only a black screen in hardware.

 

My specs are as follows:

Windows 7 2.9ghz (2 CPUs), 8gb memory, ATI Radeon 3000

Share this post


Link to post

Are you using PrBoom or PrBoom+? Also, for QZDoom and GZDoom, try running with "-glversion 3" as a command line argument. You might want to upgrade your video card in the future, as Zandronum will eventually adapt G/QZDoom's latest requirements. If both options fail, you could try running Q/GZDoom with vid_renderer 0 set, that'll put Q/GZDoom into Software Renderer mode.

Share this post


Link to post

I don't understand how to set up these "command line arguments." Could you elaborate? How do I determine if I'm running the + version of PrBoom? Also, I cannot afford to upgrade my video card at this time.

Share this post


Link to post
7 hours ago, GoatLord said:

How do I determine if I'm running the + version of PrBoom?

The folder should have "prboom-plus.exe" and "glboom-plus.exe" in it. And just to make extra sure, the latest version of prboom+ is 2.5.1.5, which can be downloaded here: http://prboom-plus.sourceforge.net/history.html

Share this post


Link to post

Almost certainly a driver issue. Try updating your graphics driver.

Share this post


Link to post

Well this is distressing. Not only did Microsoft charge me to update the drivers, but it did not solve the issues.

Share this post


Link to post
On 10/1/2018 at 1:19 PM, GoatLord said:

I don't understand how to set up these "command line arguments." Could you elaborate?

Make a shortcut of the Q/GZDoom executable, then right click and go to properties. At the end of the "Target" box, add -glversion3 outside of the quotes.

 

It should look like this:

 

"C:/Games/GZDoom/gzdoom.exe" -glversion3

Share this post


Link to post

QZDoom said

Execution could not continue.
Script error, "qzdoom.pk3:compatibility.txt" line 59:

Expected '}, got 'setsectortag'. 

 

EDIT: My bad, I was making a shortcut of the zdoom data file. I made a shortcut of the right file and it did not fix the issue.

Share this post


Link to post

@GoatLord

 

Zandronum

- You said Ketchup v5 with Smooth Doom. Tell us the error next time but I can tell you the possible error. In Ketchup, it has the 0.L typo in the blood decorate lump, so search that and just change it to 0.1....done

 

PrBoom+

- That software version should be fine for you to run. Same if you use GLBoom+.

 

QZDoom/GZDoom

- That black screen is due of outdated drivers in hardware mode. Update them asap. Otherwise, you'll have to run in software mode. Same goes for Zandronum...

 

Share this post


Link to post

Ok, so I did some quick research about your card and... apparently it doesn't even support OpenGL 3.0, so no wonder why the -glversion3 parameter didn't work.

Share this post


Link to post
11 hours ago, GoatLord said:

Well this is distressing. Not only did Microsoft charge me to update the drivers, but it did not solve the issues.

That doesn't sound right...they charged money? I've never heard of MS doing that. Did you already check on AMD's website for updated video drivers?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×