Launching Chocolate Hexen through Steam

I'm trying Hexen for the first time, so I install it with Chocolate Hexen to get the most vanilla experience I can outside DOSBOX, but I also still want to launch it through Steam and have Steam count my play time on the game, so I do the trick where you rename the executable to make Steam launch Chocolate Hexen.

 

The problem is, whenever I launch through Steam, it launches Chocolate Hexen with default settings. I'd already gone into the setup launcher, changed the controls, and set it to launch windowed. When I launch the exe directly from the File Explorer, it launches with my settings, but launching through Steam ignores these settings. I've tried looking through the config files but there are like four of them and I've tried to single out which one Steam actually uses.

 

I'm running Windows 10 if that matters.

Share this post


Link to post

have you tried using the -config parameter in the launch options through the properties on steam? it should look like this:

-config chocolate-hexen.cfg (or whatever the name of your config file is)

 

if that doesn't work, have you tried using the setup .exe through steam instead of launching directly into hexen?

Edited by bonnie

Share this post


Link to post
12 minutes ago, bonnie said:

have you tried using the -config parameter in the launch options through the properties on steam? it should look like this:

-config chocolate-hexen.cfg (or whatever the name of your config file is)

 

if that doesn't work, have you tried using the setup .exe through steam instead of launching directly into hexen?

I just tried both. The first one didn't seem to do anything. The second thing booted up the setup file, but upon saving and launching the game still went into fullscreen and reverted to default controls, no matter what I'd changed the settings to in the setup.

Share this post


Link to post

i feel like i need more information

can you upload a screenshot of the folder you're using perhaps?

i wanna see all files you're workin with

Share this post


Link to post

This is what's in the base folder. The dosbox exe is the renamed chocolate hexen exe.

base.jpg

 

Edit: I can't post now for some reason so I can only edit this post.

 

I tried the whole process again on another system (my current system only has one drive and Steam won't let me create more than one library per drive), then I copied the config files from that system to this one. Whenever I boot through Steam, Steam seems to create two new config files just outside the base folder, so I overrote those config files and set them to read-only, then something else happened.

 

Now if I launch through Steam it launches in fullscreen (even though I set fullscreen to "0" in the config files)... but WITH my changes to the controls.

Edited by RedSwirl

Share this post


Link to post

Chocolate Hexen likely can't write to Program Files due to the protected nature of the folder. You'll likely have to use -config to point it to a configuration file outside of the Program Files dir, somewhere where you normally have permissions to write files.

 

You could also run chocolate hexen briefly as administrator to set up a configuration and then run normally, or copy in a configuration created elsewhere. I wouldn't advise running as admin all the time, but you can use it to at least get something other than the default in there, if you're not going to be spending a lot of time changing options.

Edited by InsanityBringer

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now