Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
StevenC21

GZDoom Awful Screen Tearing...

Recommended Posts

Hi. So I have a new computer, and suddenly when I launched GZDoom today, I got this horrid screen tearing from the top-left of my screen to the bottom-right. I have V-Sync enabled in both GZDoom and my GPU settings. Any help guys?

Share this post


Link to post

Have you tried it with v-sync off as well? I'd also try different resolutions, I've found that it only happens on some of them. Hopefully someone can help you out further.

Share this post


Link to post

Wow I never heard of tearing happening even with vsync on. I for sure never heard of it happening in windowed... either I am missing something or I'm just lucky that vsync makes all of it go away for me in every game (although that's not always good, since vsync is shit in some games and causing horrid mouse lag). I can't force it via my video card drivers because they suck and don't even force it.

Share this post


Link to post

I'm not sure you should have vsync enabled both in the driver's control panel and in game. You could first try to disable one of them and see what it does.

Share this post


Link to post

@cacodemon345 could you please stop mentioning me in every thread related to GZDoom. If someone wants help from the GZD team they should post it on the ZDoom forums. And if they banned themselves from there (as some posting instead on DW did), well, I guess they should have thought about that before getting themselves banned.

Share this post


Link to post

The OP is out of luck if he doesn't have a ZDoom forum account.

I did hear about adaptive vsync causing tearing issues.

Share this post


Link to post

If the OP is so lazy he can't get himself to create an account. Well, I guess I'll be equally lazy and not even bother think about what went wrong on his computer.

Share this post


Link to post

Have you tried seeing what happens in software mode? It can however, be an issue with your computer (perhaps its monitor) in general, like does it happen with anything else? I know, when I first got this laptop, I had a screen tearing issue even while using a browser to read stuff. It was annoying as heck, but it gradually got better, so I dunno.

Share this post


Link to post

Everyone, this happens with all 1st person games. It only happens in OpenGL mode, and if I bump the res down to a tiny screen, it goes away, but I really want to play Doom in 1920x1080. I'd use the software renderer, but then bye bye to 3d floors...

Share this post


Link to post

Why the hell is the OP being assumed as lazy or a ban evader or something? He didn't do anything other than ask for some basic help, calm your tits.

 

So you've tried with v-sync both on and off, both in game and in your GPU settings, you've tried it in windowed mode and tried it at various resolutions? Sounds like you're running out of options - have you tried Zandronum, just to see if its an issue there as well? If the tearing is also present in Zand, I would say it probably is a good idea to ask directly at the ZDoom forums.

Share this post


Link to post
5 minutes ago, Doomkid said:

Why the hell is the OP being assumed as lazy or a ban evader or something? He didn't do anything other than ask for some basic help, calm your tits.

I was only trying to save some time for the usual standard replies that maybe OP couldn't post it on the ZDoom forums and by that logic I should come to his rescue and help him here. Keep in mind someone explicitly @ mentioned me - I didn't seek out this thread.

 

For what it is worth, I hope he finds a solution to his problem.

Share this post


Link to post

What happens if you try running GZDoom and your other games in windowed borderless mode?

For GZDoom, type "win_borderless true" in the console.

Share this post


Link to post

Well guys, it mysteriously went away. All I can say was I was fiddling with a LOT of stuff, and it suddenly worked. I, sadly, don't know what was wrong.

Share this post


Link to post

One thing is for sure, Vsync was not working. You should update your gfx drivers if you run into any more problems.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×