Question

I am having problems when I make slopes/bridges. Making slopes and bridges separatly works fine, but when I make a bridge THAT slopes it becomes invisible while in game.

I am using GzDoomBuilder (bugfix).

/Per

Share this post


Link to post

26 answers to this question

  • 0

Open console and write :

 

vid_renderer 1

 

then restart the engine / gzdoom, or change it from options > change rendering output > hardware acceleration.

Edited by dmg_64

Share this post


Link to post
  • 2

Software renderer can't display sloped 3D floors. You need to play with OpenGL rendering on.

Share this post


Link to post
  • 0
1 hour ago, scifista42 said:

Software renderer can't display sloped 3D floors. You need to play with OpenGL rendering on.

Thank you! Can you explain how that is done?

/Per

Share this post


Link to post
  • 0

Or choose "Hardware (OpenGL)" in GZDoom's IWAD selection window when GZDoom starts up.

Share this post


Link to post
  • 0

lol what if the OP doesn't have more than 1 IWAD, but yes you're right.

Share this post


Link to post
  • 0
1 hour ago, dmg_64 said:

Open console and write :

 

vid_renderer 1

 

then restart the engine / gzdoom, or change it from options > change rendering output > hardware acceleration.

I am sorry. I think it is the language barrier that makes it hard for me to get. Where do I find this "console"?

Thank you for your patience.

Share this post


Link to post
  • 0

Press tilde "~" (the key below ESC) to open it, it's like a debugging tool, or you can just follow the second method or scifista's.

Edited by dmg_64

Share this post


Link to post
  • 0
8 minutes ago, dmg_64 said:

Press tilde "~" (the key below ESC) to open it, it's like a debugging tool, or you can just follow the second method or scifista's.

Should I do this while in the game or in GZDoomBuilder? I tried both but nothing happened.

Share this post


Link to post
  • 0

In the game (assuming you play in GZDoom or Zandronum), and if it's not working for you, go to "Options -> Customize Controls -> Other -> Open Console" and see which key it's actually binded to or rebind it to whatever key you want.

Edited by scifista42

Share this post


Link to post
  • 0
3 minutes ago, scifista42 said:

In the game (assuming you play in GZDoom or Zandronum), and if it's not working for you, go to "Options -> Customize Controls -> Other -> Open Console" and see which key it's actually binded to or rebind it to whatever key you want.

Okey, I found the console and wrote the exact text (like above) several times and I get the message "Unknown command "vid_renderer1""

Share this post


Link to post
  • 0
4 hours ago, Pelle1986 said:

I am using GzDoomBuilder (bugfix).

/Per

 

Of importance is which map format you use to create the map, and which port you

want to play your map with.

 

To see the slopes you have to you use the OpenGL hardware renderer, which means

you need to start GZDOOM.

 

iEZXjQA.png

 

If you just have DOOM2, then move DOOM2.WAD into the GZDOOM folder and GZDOOM

will start right way, without displaying the selection window.

 

Edited by Kappes Buur

Share this post


Link to post
  • 0
6 minutes ago, Pelle1986 said:

Okey, I found the console and wrote the exact text (like above) several times and I get the message "Unknown command "vid_renderer1""

There should be a space between "vid_renderer" and "1".

Share this post


Link to post
  • 0
Just now, scifista42 said:

There should be a space between "vid_renderer" and "1".

I tried that as well, still unknown command :-(

Share this post


Link to post
  • 0

Which port are you using?

Share this post


Link to post
  • 0
11 minutes ago, Kappes Buur said:

 

Of importance is which map format you use to create the map, and which port you

want to play your map with.

 

To see the slopes you have to you use the OpenGL hardware renderer, which means

you need to start GZDOOM.

 

iEZXjQA.png

 

If you just have DOOM2, then move DOOM2.WAD into the GZDOOM folder and GZDOOM

will start right way, without displaying the selection window.

 

This doesn't look like my GZDoom. I never get to this "welcome-window"

Share this post


Link to post
  • 0

In "Options -> Miscellaneous Options", set "Show IWAD Selection Dialog" to "On".

Edited by scifista42

Share this post


Link to post
  • 0
5 minutes ago, scifista42 said:

Which port are you using?

Port??? Sorry, I don't know what you mean..

Share this post


Link to post
  • 0

Doom source port / engine which you play the game with, for example GZDoom, Zandronum, ...

 

I asked because if you were using just ZDoom, the command wouldn't work.

 

But if you used GZDoom or Zandronum, then "vid_renderer 1" should absolutely work. Double check for typos.

Edited by scifista42

Share this post


Link to post
  • 0
4 minutes ago, scifista42 said:

Doom source port / engine which you play the game with, for example GZDoom, Zandronum, ...

Oh, silly me... It is GZDoom

Share this post


Link to post
  • 0

Then "vid_renderer 1" should absolutely work. Double check for typos.

Share this post


Link to post
  • 0
5 minutes ago, scifista42 said:

Then "vid_renderer 1" should absolutely work. Double check for typos.

I notice something strange, when I write the command "vid_renderer 1" (with a space between the last word and number 1), the number 1 seems to be lost. I get this message "unknown command "vid_renderer""

I tried to fill out the space with _ , - and whatever... 

Still doesn't work :-(

Share this post


Link to post
  • 0

Post a screenshot with console open, maybe that will help :)

Share this post


Link to post
  • 0
7 minutes ago, Pelle1986 said:

I notice something strange, when I write the command "vid_renderer 1" (with a space between the last word and number 1), the number 1 seems to be lost. I get this message "unknown command "vid_renderer""

Are you sure you are using GZDoom and not regular old ZDoom? Because this is exactly what happens in ZDoom, which doesn't know vid_renderer. Or maybe you're using some really old version of GZDoom.

Share this post


Link to post
  • 0
2 minutes ago, scifista42 said:

Are you sure you are using GZDoom and not regular old ZDoom? Because this is exactly what happens in ZDoom, which doesn't know vid_renderer. Or maybe you're using some really old version of GZDoom.

Please forgive me! I am embarrassing myself. I was using ZDoom. I am so sorry for wasting your time. 

Now I have downloaded GZDoom and run the command. And it worked. At least I did not get any unknown-command-messages. Is that all I have to do to solve the mainproblem?

/ Per

Share this post


Link to post
  • 0

Quit the engine after you run the command and it should start with OpenGL rendering on when you launch it next time.

1 person likes this

Share this post


Link to post
  • 0
3 minutes ago, Pelle1986 said:

s that all I have to do to solve the mainproblem?

/ Per

I suppose so, (after switching renderer & restarting the game) If your sloped 3D Floor is setup correctly it should render with no issues in OpenGL renderer.

Edited by dmg_64
1 person likes this

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now