Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SiFi270

Need help running an Absolution PWAD (yes really)

Recommended Posts

So I've been checking out custom maps for the Doom 64 TC because I feel it's still worth playing as a piece of Doom history. My most recent discovery is this one, but when I try to warp to the map it occupies, the game crashes and tells me I need to use the -maxzone command to run it properly.

 

There has been another map, found here, that required me to use that command, and I was able to run that one without any problems. The difference is that the instructions for that one were more specific, telling me to use "-maxzone192" while this map isn't giving me any numbers.

 

When I googled "doom 64 maxzone" I saw people sugggesting 128 and 256 for other purposes, so I figured the number had to be a multiple of 64, but trying both of those in addition to 320 and 384 hasn't helped, so now I've come here to see if anyone understands this better than I do. I guess it could help to specifically ask @Kaiser but from what I understand he's busy and not around much.

Share this post


Link to post

I got hit with that message once while warping to a map in the Redemption Denied set. It doesn't seem to be constant, and so far I haven't had to change anything (knock on wood). How big is that map anyway? Maybe try something a lot bigger, like 512. I don't really know what to suggest unfortunately.

Share this post


Link to post

tempgrnd.wad, the one I'm trying to run, is 1344kb, while Mining Front, the one that worked with the "-maxzone192" command, was 1370kb. I've now tried changing the number to 512 and 1024, but still no luck.

Share this post


Link to post

If I remember correctly, D64 Absolution based on Doomsday 1.7.xx versions, where "-maxzone" parameter means how much RAM will be allocated for the port. For example, a later Doomsday 1.8.6 version can use no more than 256MB RAM, for this reason, it makes no sense to set more memory with the -maxzone command.

Try this command syntax for 128MB allocated for the port: -maxzone 128m

If it does not help, and you again crash: add "-verbose" parameter to your command line, it will give a more detailed log, after crash find Doomsday.out (or Absolution.out) in your D64 Absolution folder, look at it, maybe there you will find a solution to your problem. Or attach this log file here, may be I can help.
 

Share this post


Link to post

128m worked, thank you. What's still a little confusing to me is how before, having a space between "maxzone" and the number wouldn't allow me to load any level at all, but with 128m, the space made all the difference. Not too big a deal, I suppose.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×