Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
GarrettRightBackAtYa

.net Framework 3.5

Recommended Posts

OKAY I FUCKING HAD THIS MOTHER FUCKING PROBLEM FOR FUCKING EVER SO IF THERE'S NO FIX THEN I'M GONNA FUCKING KILL MYSELF

Doom Builder 2 installer said that i need to install .NET FRAMEWORK 3.5 So I TRIED TO INSTALL IT AND IT DIDN'T WORK

Is There A Way To Install Doom Builder 2 Without .net framework 3.5 and have it work?

Share this post


Link to post

What didn't work about it? If you can't install .NET, it's usually because you already have an updated version, or a more serious problem.

Share this post


Link to post

Well why can't you install It? What problems are you having exactly? Maybe you can use another editor that doesn't require .net like Eureka in the meantime?

Share this post


Link to post
Posted (edited)

I've had this problem before with old operating systems like XP Pro. It is sometimes because the install you have is dodgy.

Try to find another source of the .net 3.5 and it might work.

 

Edit:

And I know how frustrating this is. Old versions of .net are bloated pieces of crap that are often installed for just 1 application. Note, not all versions of .net supersede older versions. Some are completely separate and installed in parallel (not over each other). 

Share this post


Link to post
4 hours ago, alowe said:

I've had this problem before with old operating systems like XP Pro. It is sometimes because the install you have is dodgy.

Try to find another source of the .net 3.5 and it might work.

 

Edit:

And I know how frustrating this is. Old versions of .net are bloated pieces of crap that are often installed for just 1 application. Note, not all versions of .net supersede older versions. Some are completely separate and installed in parallel (not over each other). 

 

As far as I know, this is only true with older versions. If he's running Windows 7, 4.5.2 comes as a Windows Update eventually, and supersedes all previous versions, but I'm also not totally sure. :)

 

14 hours ago, GarrettRightBackAtYa said:

It Doesn't Install At All

i dont even have .net framework on my pc at all!

or at least i cant use it at all

 

Again, what does not work? Does it try to install? Does it throw up an error message? What operating system are you running?

Share this post


Link to post
Posted (edited)
14 hours ago, R4L said:

What didn't work about it? If you can't install .NET, it's usually because you already have an updated version, or a more serious problem.

 

if i'm not mistaken, you can develop .NET 3.5 applications even if you have an updated version.

 

I'm a programmer; we use .NET 4.5 and older versions.

Share this post


Link to post
19 minutes ago, Pure Hellspawn said:

 

if i'm not mistaken, you can develop .NET 3.5 applications even if you have an updated version.

 

I'm a programmer; we use .NET 4.5 and older versions.

 

At my job our programmers use 4.5 and older as well, especially in IIS. I just remembered having 4.5 and then having 4.5.7 now because of a Windows Update. Should still work of course.

Share this post


Link to post

Yes we can fucking swear.

 

We really need to know what version of Windows Mr. GarrettRightBackAtYa is using.  In Windows 10, for example, .NET 3.5 is included in the Windows Features list and you have to check a box to "install" it.  I have no idea what the default is.

Share this post


Link to post

Doom without swearing is like Saw without blood :D

But I only swear when it is justified. Like not being able to play Doom.

Share this post


Link to post
1 hour ago, alowe said:

Doom without swearing is like Saw without blood :D

I think you might be playing a different game than the rest of us.

Share this post


Link to post

We could sample, "Oh fuck it!" and use that for death events. Imagination is the only limit. Beats "Medic!" though it's funny they call that after their head is blown off. Bit late bud :D

 

Need a mod where you can kill goths and emos. They can say, "Oh fuck it!" in a depressed way lol. Make it dark humour :D

Share this post


Link to post
5 hours ago, GarrettRightBackAtYa said:

i have WINDOWS 10

 

That's fantastic. Now, can you answer the other questions that I've asked two times now?

Share this post


Link to post
Posted (edited)
4 hours ago, R4L said:

 

That's fantastic. Now, can you answer the other questions that I've asked two times now?

You asked a question?

 

Spoiler

Lol. Just fuckin witcha :D

 

The other question I have is have you tried downloading an alternative copy of the .net 3.5 install, to rule out the previous one being a dud?

Share this post


Link to post
15 hours ago, GarrettRightBackAtYa said:

i have WINDOWS 10

You do not need to download anything to make this work.  Search for "Turn Windows features on or off" in the start menu, run that, and you should see the dialog below.  Make sure the first item is checked (the filled box is fine; you don't need the two sub-items).

Win 10 features.png

Share this post


Link to post
6 hours ago, GarrettRightBackAtYa said:

IT DOESN'T WORK

Have you tried downloading a different install for .net 3.5 yet?

Share this post


Link to post
Posted (edited)

If .net 3.5 is installed (as you claim), how do you know .net is the problem? What leads you to this conclusion or informs you of this?

Share this post


Link to post
11 hours ago, alowe said:

Have you tried downloading a different install for .net 3.5 yet?

There is no .NET 3.5 download for Windows 10.  It's actually supposed to prompt you to enable the feature I showed if it's disabled when you try to run a .NET 3.5 app.  https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

 

I think it's pretty likely the guy is trolling or using some hacked pirated version of Win 10 that's broken.

Share this post


Link to post
Posted (edited)
On 19.03.2018 at 4:47 AM, GarrettRightBackAtYa said:

OKAY I FUCKING HAD THIS MOTHER FUCKING PROBLEM FOR FUCKING EVER SO IF THERE'S NO FIX THEN I'M GONNA FUCKING KILL MYSELF

Children...

 

Tell me why Doom Builder. Why don't GZDoom builder instead?

Share this post


Link to post
Posted (edited)

In times of yore, running the DB2 installer would install all necessary software to have a working editor.

That was with Windows 7, for Windows 10 give it a try it just might work.

 

8 hours ago, GarrettRightBackAtYa said:

someone needs to make a version of doom builder that can work with .net framework 4.0 / 4.5 alone because i have that

 

GZDoom Builder Bugfix, from version r3018 on, uses Microsoft .Net Framework 4.6.1

both versions, x86 and x64.

 

Edited by Kappes Buur : GZDBBF link

Share this post


Link to post

If you're used to the DB2 interface, is it that hard to use GZDoom? Just asking cause I've never used GZDoom.

Share this post


Link to post
5 minutes ago, alowe said:

If you're used to the DB2 interface, is it that hard to use GZDoom? Just asking cause I've never used GZDoom.

I was afraid of that at first. However, GZDB's interface is extremely similar to that of DB2. If you've already mapped in UDMF on DB2, switching to GZDB shouldn't be hard to get used to at all.

 

Also correct me if I'm wrong but I believe GZDB can run if you have a higher version of .NET instead of 3.5

Share this post


Link to post
12 hours ago, Kappes Buur said:

In times of yore, running the DB2 installer would install all necessary software to have a working editor.

That was with Windows 7, for Windows 10 give it a try it just might work.

 

 

GZDoom Builder Bugfix, from version r3018 on, uses Microsoft .Net Framework 4.6.1

both versions, x86 and x64.

 

AAAAAYYYY

IT WORKED

WOOOOOOOOOOOOOO

MISSION COMPLETE TO YOU MY GOOD SIR

Kappes Buur YOU EARN THIS MEDAL FOR YOUR HONORSHIP

Badge.png

Share this post


Link to post
Posted (edited)
16 hours ago, alowe said:

If you're used to the DB2 interface, is it that hard to use GZDoom? Just asking cause I've never used GZDoom.

 

The GZDB interface builds on the DB2 interface. It's the same, just plus a bunch of useful stuff. If you're comfortable with DB2, you'll be fine with GZDB (remember to use the Bugfix version).

 

Also GZDB is clever: you pick which source port you're targeting at the beginning of each map (vanilla, Boom, GZDoom etc.) and the program customizes the interface to match. So if you only make Boom maps (for example) you won't see any advanced GZDoom options or features.

Share this post


Link to post
Guest
This topic is now closed to further replies.
×