Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Sign in to follow this  

    EDGE 1.26 ...


    Arioch

    Fanatic has updated the EDGE site with the information that EDGE 1.26 has been released! The changelog for this latest version can be found at the EDGE site, and downloads are available for the win32, DOS, and linux versions.

    Sign in to follow this  


    User Feedback

    Recommended Comments

    I have tried -bpp 4 and -bpp 32, to no avail. It seems to insist on 16bit mode (gledge).

    I run all games in 32bit, shouldn't have to swap display mode just for edge...

    Share this comment


    Link to comment

    Fuck.. there goes my weekend. I hope it's somewhat non time-consuming to convert from version 1.24

    Share this comment


    Link to comment

    some of these are engine problems (gledge), others qdoom specific, sorry for the mix:

    - missing 32bit mode, as mentioned below
    - fov slider is nice, but doesn't work (introduces HOM beyond 90)
    - aim seems to "jump" when firing weapons. Don't say this is a feature or I'll cry.
    - I get very choppy fps, on a T900/512/GF2 (runs Q3 and any other game at silky smooth fps)
    - the tall elevator on e3m1 crashes the game repeatedly.
    - as I said with the test, and I'll say it again: lighting looks VERY bad. You combine textures that are very non-contrasting to cope with quake's lighting model, with an engine that cannot do contrasting lighting (well, it can, at the expense of polys). Result: the worst of both worlds in terms of lighting.

    Sorry for coming up only with bad points, sure there are many good points but they are more obvious :)

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    I'll look into those when I get home.

    The weapons kick when you fire them, this *is* a feature. I think I'll put in a request to turn this on or off in the menu system, can can see some people not liking it.

    Share this comment


    Link to comment

    Aard: was that E3M1? I thought it was E3M2. Ohwell.

    Well. I think the view bump far to much up and down when you run. and the swimming is horrible. In E2M1's water secret I was like shot out of a cannon when I swam down that tube. I flew all the way across the room up on top of the waterfall. and in that map with the cracked nuke tube with the quad in it, I didn't see anything and I couldn't get out of it either. (probaly cause I couldn't see anything)

    Damn. I'm only complaining. BTW Marc. I'm very impressed by your maps. I don't think I've ever seen such extensive use of 3d objects before in a doom map.that must have been pretty time consuming making all that.

    Share this comment


    Link to comment

    Well, 1.26 seems to address most, if not all the major problems I had with 1.25.

    It has a lot of nice new features that I spotted on a fairly quick run through too.

    The bobbing action when walking still seems a little severe when moving, especially strafe running though.

    I usually play in software mode, but I gave the GL mode a spin too. The thing shadows, that look like shadows in software mode, actually used the sprites in their full colour in opengl mode, so the enemies etc looked like they had another copy of themselves stuck to their feet.

    In GL mode the levels seemed to all be full brightness everywhere too. Mind you, I didn't play in GL mode long enough to see if there was some setting I was missing.

    Share this comment


    Link to comment

    Hey bud, your new version of Edge doesn't work: "DDF_MainReadFile: Unable to Open: '.language.ldf'"

    I want a working copy on my desk by 1900.

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    Make sure EDGE.WAD is in the same directory as EDGE32.EXE or GLEDGE32.EXE.

    If that's the case, what are you typing from DOS to run it?

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    Runs incredibly well here. Ran fine on my P3 600 128 megs RAM, runs even better on my P3 1ghz 512 megs RAM.

    Most people have no problems with DirectX 8 and the lastest drivers available for their card. Dunno what else to say.

    Share this comment


    Link to comment

    mystic : I run gledge on a p233 tnt2 and on the standard doom/doom2 levels framerate is quite normal.

    however in qdoom and cory's df3 demo framerate drops to almoust zero (does this in edge too).

    i have narrowed it down to some causes, one seems to be spawning alot of sprites, like the chaingun in immoral conduct. Firing that for some seconds and framerate is gone, likewise if the chaingunners ejects shells (ic again)

    Share this comment


    Link to comment

    Ahh, saving. And I havn't found a bug with it yet (saving, that is). Problem is, I just can't be ARSED to convert DDF from 1.24 to 1.26. I wish it had backwards compatibility.

    Share this comment


    Link to comment
    Guest Striker

    Posted

    Turn off the autoaiming and the weapons will stop jumping the aim jumps wherever the autoaim is.

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    That stops rain on the first two levels and kills ALL ambient sounds, which can be a bitch on FPS on some systems. Always runs fine here tho.

    Share this comment


    Link to comment

    Hm, It's running great for me in OpenGL. a bit slow in Software at 800x600 though.

    I really liked the design of these levels. But I found the nukeage to be much prettyer in the Qdoom test version. now it was far to dark.

    Share this comment


    Link to comment

    I converted all my ddf from 1.24 to 1.26, and edge starts up fine and I can start a new game, but as soon as I do anything requiring a sound, like jump, fire a weapon, alert a monster, etc, I get to play Desktop Commander in 640x400 splendor.

    There are no errors or warnings given AT ALL, and the debug (-debugfile) text has nothing to say. I use 11025 khz mono sounds only (same as Doom), and there's nothing wrong with the player's states. It seems once I'm in the game (normal Doom2 maps), doing anything short of moving around (including pressing ESC), will crash.
    The wad contains weap/sfx/thing/atk/lang lumps only.

    I'm stumped.. It's probably something simple, but damned if I know what.

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    Sounds like you're using old GL nodes maybe?

    If you want, zip up your files and email them to me, or put them online for me to grab and test out.

    Share this comment


    Link to comment

    Hey fanatic, what ever happened to the proposed "beam weapons", or attacks that act like pistol shots but actually draw something on that trace attack rather than nothing (like a solid laser beam).

    ...been waiting for this for railgun implementation (i mean, hey, even a striong of puff objects would be nice). Im getting really sick of making projectiles have a speed of 100 or more and their puff objects are about a mile inbetween each other (and the fact that it is a projectile means that all of the puff objects are at different heights while they are rising, which totally gives away the effect).

    Share this comment


    Link to comment
    Guest Fanatic

    Posted

    We put in an attack special for tunneling, was that what you were looking for?

    You can also set the floating speed to 0, so the puffs don't raise.

    Share this comment


    Link to comment

    But the problem is that I want all of the puff objects to rise, but be at the same level while rising (it would be like the projectile travelled and hit something, and it's puff objects were frozen in time until the projectile hit, then all of them rose and animated at once).

    Also, to make it seem instantaneous i would have to set the speed upwards of 100 or more, and with even only 1 frame lasting 1 tic long leaving a puff object behind, the trail wont exactly be consistant... (it'll ahve big gaps between the puff objects, like at least 32 map units whereas 16 map units would be more ideal).

    -----
    And does edge 1.26 have additive options? Because translucency is simply not enough.

    Share this comment


    Link to comment


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×