Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Sign in to follow this  

    Risen3D v2.2.07 released


    hawkwind

    As the subject states, Risen3D v2.2.07 has been released. It is available from the Risen3D homepage. A list of some of the changes can be viewed here. There are also new hi-res textures for the Icon Of Sin by Sitters, and new models by Abbs and Sitters.

    Sign in to follow this  


    User Feedback

    Recommended Comments

    This is the first release of Risen that has actually worked for me (I gave up on Doomsday a long time ago...). It seems to run pretty well and the alternative model pack isn't too bad though I'm not really sure of the purpose of this sourceport. What does it offer that's different from other sourceports out there? Just curious. :)

    Share this comment


    Link to comment
    PFL said:

    I'm not really sure of the purpose of this sourceport. What does it offer that's different from other sourceports out there? Just curious. :)


    Research information on the homepage and/or read the included docs. Seek and you shall find.

    Share this comment


    Link to comment
    walter confalonieri said:

    All right, i've installed the program, but it don't load me correctly the 3d models... how i can do?


    Have you at least downloaded and installed correctly r3d-models1.exe and r3d-models2.exe ?

    Share this comment


    Link to comment

    I, too, seem to be having problems with using the Risen3D install with models enabled. I've got Windows Vista SP2, and an ATI Radeon HD 4850. It always crashes out 1-2 seconds after loading the level.

    I'm only working with the standard model packs installed (r3d-models1.exe and r3d-models2.exe). When installing them, Vista gives me a warning about "this may not have installed correctly"... I've tried the options "reinstall with suggested settings" and "this installed correctly", but neither seem to make a difference.

    I've tried going into the Models tab on the launcher and disabling sets of models, too... If I disable Monsters/Player and HUD weapons, I can run around the map for longer (although it's for a variable length of time... on MAP30 sometimes it will crash in 3-5 seconds, sometimes I'm able to pick up weapons/items, go through the teleport, activate the bossbrain, and then it'll crash when a Baron throws a fireball).

    It's quite confusing. Any help is much appreciated!

    Share this comment


    Link to comment

    Abbs' has advised me to inform those of you having problems to please email the development team with a copy of your Risen3D.out file and as much info as you can.

    They don't bite ... ;)

    Share this comment


    Link to comment

    I did get a hold of Abbs, and we were able to track the issue down to everything being a videocard driver problem :P

    Really enjoying the model packs and some of the custom levelsets. A great port!

    Share this comment


    Link to comment


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×