Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

YukiRaven

Members
  • Content count

    4185
  • Joined

  • Last visited

About YukiRaven

  • Rank
    Will DDR for food

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Single Status Update

See all updates by YukiRaven

  1. I'm rather stumped, and since I'm trying to get as much information as I can, I figured I'd ask here as well as other people.

    I've got a 1992 Subaru Legacy Turbo that won't start. The engine acts like it wants to, but doesn't start. Sometimes it almost starts, but doesn't.

    The battery is good and has a good connection. It isn't flooded either, as I let it sit overnight before trying it again. I replaced the fuel filter today just to be on the safe side, but it's not starting yet.

    My grandpa and friend both thought it seemed like it wasn't gettting enough fuel.

    Ideas?

    And yes, not only do I come to Doomworld for physics questions, but also for car questions ;)

    1. Show previous comments  1 more
    2. Quast

      Quast

      You don't happen to have some type of anti-theft device on this car do you?

      It almost starts? So it's turning over then right?

      I'd say check your spark plugs first.

    3. Gokuma

      Gokuma

      Make sure you're not out of cells.

    4. YukiRaven

      YukiRaven

      I called a place up earlier today and it sounds like it may be the crankshaft position sensor. I was thinking this myself, but had no way of testing it.

      It seems to be getting a spark, however.

×