Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Coraline

Members
  • Content count

    1178
  • Joined

  • Last visited

About Coraline

  • Rank
    Senior Member

Recent Profile Visitors

3743 profile views

Single Status Update

See all updates by Coraline

  1. Results of testing compile of latest Edge on Linux.

     

    I tried to compile EDGE on Linux.  I failed.

    These are the library requirements that I encountered.

    I don't know if all these libraries are really required, or if some are just for Windows.

     

    3DGE Library Versions
    ===================
    This document outlines the libraries 3DGE needs for compile.

        Please note that all libraries **must be statically linked** to the EXE (except for SDL2 on Win32).
          -- WHY, on Linux too ??

    ----------
    System: Slackware 14.2,  Linux 4.4.88
    I have already upgraded to the latest packages of the the Slackware site,  8/2018.
    Did you list the library versions according to the features you need,
    or did you just list whatever you had on the system you were
    developing on ?

    I have recently upgraded my system, and I do program development.
    There are way too many latest libraries listed here, and some are the
    latest bleeding edge versions.
    I suspect that these are not actually the required versions.

    Out of 10 libraries required, there are 5 libraries that I would have to
    upgrade or install.
    If these were available as Slackware packages, it is likely that I would already have them.
    These may not be available as Slackware packages for some time.

     

     

    Requirement:    /GLEW-2.0.0
    PROBLEM>>  dont have this package
    Have:  glew-1.13.0
       

    Requirement:    /libcpuid (0.4.0, upgraded from 0.2.2)
    PROBLEM>>  dont have this package


    Requirement:    /libjpeg-turbo (1.5.2, developmental version)
    PROBLEM>>
    Have: libjpeg-turbo-1.5.0
    >>> Are you actually using features from 1.5.2 that are not in 1.5.0 ??


    Requirement:    /libogg-1.3.2
    Have: libogg-1.3.2
          liboggz-1.1.1


    Requirement:    /libpng16 (lpng1632)
    PROBLEM>> dont have png16
    Have: libpng-1.6.27


    Requirement:    /libvorbis-1.3.5
    Have: libvorbis-1.3.6
          libvorbis-tools-1.4.0


    Requirement:    /physfs (pre3.0, upgraded from 2.0.3)
    PROBLEM>>>  bleeding edge version required
    Have: physfs-2.0.3


    Requirement:    /SDL2 (2.0.5, upgraded from 2.0.3)
    Have: SDL2-2.0.5
          SDL2_gfx-1.0.3
          SDL2_image-2.0.1
          SDL2_mixer-2.0.1
          SDL2_ttf-2.0.13


    Requirement:    /SDL2_net-2.0.1 (deprecated. . .?)
    PROBLEM>>  dont have this library, and it is deprecated ??


    Requirement:    /Zlib-1.2.11 (upgraded from 1.2.8)
    PROBLEM>>  requires a minor version upgrade
    Have: zlib-1.2.8
    >>> Are you actually using features from 1.2.11 that are not in 1.2.8 ??


    Cross-Compile users (Unix-based) must build these libraries from scratch. Just look
    at the version table above and you should be fine.

×