Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

solarsnowfall

Members
  • Content count

    64
  • Joined

  • Last visited

Everything posted by solarsnowfall

  1. solarsnowfall

    ACC++ Project Announcment

    Agreed. Simple string concatenation has been on the collective wish list of a great many end-users since time and memorial. It would be a pity to come out on the other side of this and still have to employ shitty hackery to get around this shortcoming. Not that saying that makes implementation any easier... Oops, bumped the thread. Eh, I don't make it around that much anymore...
  2. solarsnowfall

    [2.0.1.1157] Multiple Sessions

    Let's say you've got 2 Doom Builder sessions open and you're editing the scripts for each map. If you close one Doom Builder session, you still have one Doom Builder session running and two script editor sessions going. Shouldn't Doom Builder close the script editor session that's linked to teh Doom Builder session that was just closed?
  3. solarsnowfall

    [2.0.1.1157] Multiple Sessions

    Noted.
  4. solarsnowfall

    [2.0.1.1157] Multiple Sessions

    And when you go to close out of all your sessions this produces an error which prevents you from exiting Doom Builder.
  5. I've run into this error 4 times now on my first map project in DB2. It seems to happen quite randomly, but always happens during a texture paste in Visual Mode. I get an error and am given the option to continue or quit. Not wanting to lose all my progress, I select continue and save. Upon saving, I'm told that nodes were not built due to an error (which wasn't there seconds ago). If I close the map and open it up again, nothing in the map is there. No lindefs, no verteces, no things, nothing. So I open up the TEXTMAP lump to see what can be seen and I come across the last sector entry which always looks something like this.sector { heightfloor = 0; heightceiling = 192; texturefloor = "FLOOR0_1"; textureceiling = "F_SKY1"; lightlevel = 192; !virtual_sector = 0; }It always contains that last command, !virtual_sector = 0;. If I remove that command, I can open my level back up in DB2 and continue editing. The reason that this is so annoying is that once I trigger this error, I can't do much of anything without generating the quit/continue error message. I pretty much have to stop editing, close the map, and fix the TEXTMAP lump before I can continue editing the map. Vista 64 Intel E6750 4.00 GM Memory nVidia 8800 GTX
  6. solarsnowfall

    UDMF Texture Paste in Visual Mode Error

    Yea, looks like you got it boss. Good work.
  7. solarsnowfall

    UDMF Texture Paste in Visual Mode Error

    I just produced it twice after pressing Ctrl+V in Visual Mode after pasting some geometry in Sectors Mode. The first time I "pasted" then mouse clicked to paste after realizing that Ctrl+V had not achieved the desired effect. The second time was upon exiting Visual Mode after pressing Ctrl+V. It seems that even though texture pasting is bound to a mouse button I still have a habbit of pressing the Ctrl+V from time to time.
  8. solarsnowfall

    UDMF Texture Paste in Visual Mode Error

    Oh yea, almost forgot. After removing the TEXTMAP entry and making my level editable again, there is always at least one sector that gets screwed up and all two-sided linedefs associated become 2 seperate lines layed on top of eachother, as though the geometry wasn't merged properly. And no, I've not turned off Merge Geometry.
  9. Hello. I've updated the keywords and constants list found here in the ZDoom Wiki. It was quite out of date. There are a total of 59 missing entries in the list currently distributed with Doom Builder 2. Some suggestions for the Script Editor 1) The ACS cfg should be checked with each session of the Script Editor, not each session of DB2. This would make checking updates much easier. 2) Please add an option in the Script Editor Preferences to allow for custom tab spacing. Thanks for DB2.
  10. solarsnowfall

    Updated ACS Configuration & Script Editor Suggestions

    The problem seems to be that none of the new entries are recognized. Just pasting the list of constants into the script editor shows that none of the additions highlight.
  11. solarsnowfall

    Updated ACS Configuration & Script Editor Suggestions

    Well the only reason I suggested #1 is because I seem to be having difficulties seeing the changes in the DB2 Script Editor. The code for UnmorphActor is clearly in my file:UnmorphActor = "UnmorphActor(tid, force)";However, it does not highlight in the Script Editor. I more or less did the same thing I've always done when maintaining the cfg at the Wiki; edited the lists and left the top commands alone. Have I edited my ZDoom_ACS.cfg incorrectly? ...the whole config...just click link above...
  12. solarsnowfall

    Knee Deep in ZDoom released

    Sounds like somebody wants a cookie.
  13. solarsnowfall

    Doom Builder's ACS Editor

    CodeImp, if you haven't noticed, a few others and I at the ZDoom forums have been keeping an up-to-date version of the ACS.cfg here. Perhaps that might make something easier for you. I thought I'd raise one issue here. I've noticed that DB's ACS editor tends to lag when handling long strings. I've noticed this in instances of defining long string arrays, using functions with many arguments, or when /* */ commenting out large chunks of code. Any chance this can be improved upon?
  14. solarsnowfall

    Doom Builder's ACS Editor

    Yes yes, I understand. Heh.
  15. solarsnowfall

    Doom Builder's ACS Editor

    Yes yes, I understand. Heh. I wasn't expecting an update for anything like that.
  16. solarsnowfall

    Doom Builder's ACS Editor

    FYI, the ZDoom ACS config has been editied several times over the last couple of weeks, as randy has added a butt-load of new ACS functions. http://www.zdoom.org/wiki/index.php?title=Doom_Builder_ACS_Configuration
  17. solarsnowfall

    Doom Builder's ACS Editor

    A long comment./*comment comment comment comment comment comment comment comment comment comment comment comment */It begins to lag quite visibly between my key strokes and the time the character is printed on the screen at the last word. If I keep going, the lag progressively worstens.str string = "This string is somewhat long, but not overly so. Right about here I see the same problem."It starts to lag in the beginning of the second sentence. And I know I've run into the same problem when writing out large functions with several arguments, which would have had equations or other functions passed through the arguments. But, I can't seem to replicate it now. It may have just been a HUDMessage with a long string. Oh, and if it matters at all... XP Prof SP 2 Athlon 64 3500+ 1 GB of RAM Radeon 9800 Pro
  18. I've been trying to use 256x256 PNGs for textures and flats. I use Load (rad data) to insert them between TX_START and TX_END. To make them show up in the game, I have to specify an x and y value. In doing so, XWE converts the image to the doom pallet. How can this be circumvented?
  19. solarsnowfall

    Could not find required lump PLAYPAL

    Simple enough. Trying to create a new wad in Doom Builder for ZDoom in Hexen Format. When doing so I get 2 warnings, can't find PLAYPAL, can't find TEXTURE1 and TEXTURE2. Anything I try to make is unplayable. Have looked throughout this forum but haven't found anything usefull. Anybody point me in the right direction?
  20. solarsnowfall

    Importing high res 8bb PNGs for textures/flats.

    Well when adding textures XWE does have the x and y fields in the top of the display window, and that gets them to display in game. It's just when setting them to pngs that aren't formatted to the doom pallet, they get converted. Unless I'm missunderstanding your last post.
  21. solarsnowfall

    Spawn friendly monsters?

    That's not what I meant by working example. This is why I thought you couldn't use it, after trying. Not just me, it's been a problem for a lot of people. http://forum.zdoom.org/potato.php?p=148177&highlight=#148177
  22. I've been using the Doom Builder compiler to write all the ACS for my WADs, for quite some time now. But today I crack it open and get this error message when I go to compile. I've never had this problem before. And while I'm not the only one who uses this computer, I certainly haven't made any changes to my system. Any sugguestions for a quick fix?
  23. solarsnowfall

    Um, compatibility issues with the ACS Compiler?

    Thank you sir.
  24. solarsnowfall

    Spawn friendly monsters?

    Ok, where's your working example? A lot of people would like to know over at the Zdoom.org forums.
  25. solarsnowfall

    Um, compatibility issues with the ACS Compiler?

    Those instructions might have been helpfull, accept I can't even access my command prompt (no apparently, although I was just using it yesterday...). So it seems the problem is more than that. I was hoping CodeImp might know wich system files I would need to download so I could at least get the ACS compiler working again...
×