Doom Builder on Windows Vista - How To

Because Windows Vista is not so friendly to "classic" Windows applications, you need some manual changes to your Doom Builder installation to get it to work in Vista. Here they are, thanks to Mechadon.

1) Install Doom Builder in a directory OTHER than "Program Files".

2) Download this DLL file and unzip it to your Doom Builder directory.

3) Find Builder.exe where you installed Doom Builder, right-click it and choose "Properties". In the "Compatability" tab, check the box that says "Run this program in compatiblity mode for:" and choose "WinXP (SP2)" from the drop-down box.

4) For people experiencing an "Error 5 - Invalid procedure call or argument" error on Windows Vista, please read tannermann's solution.

Now you should be able to use Doom Builder on Windows Vista, enjoy.

Share this post


Link to post

Run-time error '48':

File not found: 'msvbvm50.dll'

Share this post


Link to post

Then msvbvm50.dll is probably not in your System directory. Note that this directory is named slightly different on different versions of Windows. I believe in Windows XP it is C:\Windows\system32\, not sure what it is in Vista.

Share this post


Link to post

I know where the system folder is, and I can assure you that that dll is in there, but it still gives an error...

Share this post


Link to post

Maybe you have to register the file for the OS to use it? With regsrv32, I mean (assuming that is still the name of the file in Vista).

Share this post


Link to post

This problem happens on any OS, not just Vista.
There was actually 2 DLLs I needed for Win2000 to work. Quick google of them fixed it.

Share this post


Link to post

Jonathan: Dumping the DLL in the Doom Builder directory should fix it.

Share this post


Link to post

Thanks Planky, I have updated my initial post accordingly.

Share this post


Link to post

Thanks, I wish you wouldnt have the files stored where those really dodgy 'fix your registry free' type adverts are, Im sick of having to clean peoples computers after they click on those type of adverts

Share this post


Link to post

Also, you might want to add that running it as Administrator might fix some problems as well.

Share this post


Link to post

Thanks! It worked first try! Not sure why I never tried Doom Builder before, but this would be my first go at it. We'll see how it stacks up to DeepSea!

Thanks to those who put this little guide together.

Share this post


Link to post

I've uploaded all of the libraries used at http://files.filefront.com/Doom+Builder+Libraries/;9306588;/fileinfo.html in case any others are missing

Save this in the Doom Builder folder to get visual styles in vista (xp has drawing glitches)

Builder.exe.manifest

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
<assemblyIdentity version="1.0.0.0" processorArchitecture="X86" name="ZDL.ZDL.ZDL" type="win32" />
<description>ZDL</description>
<dependency>
<dependentAssembly>
<assemblyIdentity type="win32" name="Microsoft.Windows.Common-Controls" version="6.0.0.0" processorArchitecture="X86" publicKeyToken="6595b64144ccf1df" language="*" />
</dependentAssembly>
</dependency>
</assembly>

Share this post


Link to post

Don't know if this thread is still alive but to get DB working in Vista w/ or w/o the UAC. (This is if you have it in the default install location)

Anything that requires admin rights should pop up a UAC box, if it's disabled then you may have to log in under an admin to adjust things.

1 - REQUIRES ADMIN RIGHTS) Right click properties on the Doom builder folder (defaults to C:\Program Files\Doom Builder) and go to the "Security" tab.
2 - REQUIRES ADMIN RIGHTS) Under the "Everyone" user or your username, Go to Change permissions or advanced and make sure all the checks except "Special Permissions" (it's grayed out anyway) are checked (so you have Read/Write/Execute permissions)

3 - REQUIRES ADMIN RIGHTS) Press OK and a box will ask you if you want to apply the permissions to just the folder or everything inside, choose everything inside and press OK

4) Download MSVBVM50.DLL and place it in the DB Folder or in C:\Windows\System32 (REQUIRES ADMIN RIGHTS) if you want it available to every app (Be sure to get one that matches your system/language!)

5 - OPTIONAL) if DB crashes for unknown reasons, right click Properties, go to the "Compatibility" tab and choose Windows XP Service Pack 2. Whenever I used DB in Vista, I never had any problems.

People who want to read this are:
1] People who do not want to Install Doom Builder in a directory OTHER than "Program Files"
2] People who just rapidly press "Next >" in the installation wizard
3] Union Aerospace Corporation Employes
4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!

btw the "Error 5 - Invalid procedure call or argument" is basically saying that you don't have the privs to save or modify files/registry entries.

Hope this helps!

Share this post


Link to post

GhostlyDeath said:
4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!

Quite true; the real reason he's hacking into people's computers is because he's an UAC informer, and is on the lookout for people (especially among those mentioned in case 3 above) distributing secret UAC base plans in the form of wads!

Share this post


Link to post
GhostlyDeath said:

4] People who won't run Doom Builder under admin rights because they are afriad that CodeImp is secretly taking over people's computers with Doom Builder... which isn't true!

Shhh! It's true, but only you and me know now, ok?!

Share this post


Link to post

Hmm I got something failing.
It first started up quite normal.. but doing anything, like pressing 'new map' would make it crash. That is fixxed now because of that dll file. I als run it as compability mode. The onlything now is when I configure doombuilder, I tell doombuilder where it can find all the iwads, and when pressing ok, it says: error 9 subscript out of range.

kinda failed so, I have admin rights and even tried running it as administrator by right clicking. Does doombuilder just really fails on vista? :o

that'd be bad!

any help?

and oh yes, hello to all!
plas!

Share this post


Link to post
geit said:

I tell doombuilder where it can find all the iwads, and when pressing ok, it says: error 9 subscript out of range.


I'm getting the same.... I really would like to Map for GZDoom and ZDoom, but this problem is occuring to where cannot do so. I too did all the steps, but this one comes in.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now