BIG sprite problems

Okay, I was working on v1.1 of mouac when i ran EDGE, and it said my s_end was missing. Now, I know what that is, but since it disappeared, all the sprites are now in the Graphics section and do not work in game as they should, instead showing the original doom sprites and nothing functioning correctly. How can I revert my sprites back to normal??? I am using wintex.

PLEASE HELP!!!!!!

Share this post


Link to post

Try copy-and-pasting all your graphics entries into a new wad, making sure you choose 'select sprites' first, as this will generate the start/end markers automatically.

Share this post


Link to post

I seem to have a terrible time getting the job done with Wintex. I can create a new entry s_end or ss_end, but Wintex does not let me put it where I want it, nor does it see that entry as a "marker". I can open another wad with a ss_end entry, copy and paste it with Wintex into the wad missing the entry, but again it copies to the end of the list of entries and does not function properly.

XWE, on the other hand, handles this job very easily. You can create a new entry, ss_end, and XWE properly identifies it as a marker. Then you can simply drag and drop the marker at the end of your sprites list.

DeePsea can handle this work, also Lumptool I think.

Edit: This post is not in answer to Ultimate Doomer, his idea should work too.

Share this post


Link to post

Ok iv been changing sprites and sounds for icd-se.wad for awhile now. Dont worry im not going to distribute it and if i was id give him the credit anyway im wondering how i go about adding a new patch for walls like starting from scratch. Im using WadAuthor and wintex 4.3 for editing i need to use the doom 2 configuration file for WadAuthor so how would i go about doing this so i could put it in my own Wad?

Share this post


Link to post

You might have some confusion. The doom2.wcf file has nothing to do with Wintex. You will do the patch work with a graphics program and put them in the wad with Wintex. Then, with Wintex, you typically have to use the patch in a texture, either an existing one or a new one. Once the patch/texture is in the wad, WadAuthor should be able to see it and use it.

Share this post


Link to post

Ok im using the doom 2 wcf file with WadAuthor beacuse there isent one with icd se but i cant change data in the doom2 data and if i add a new patch to the icd se wad it dosent show up in the game when i run it i cant choose a new patch to use while im running wad author while creating a wad a new level. So im wondering how i can use a totaly new patch??

Share this post


Link to post
Tyockell said:

how tall r u? wow ur that tall geez i dident kno they stacked shit dat high!


Full Metal Jacket. RARAR.

Share this post


Link to post

lol right on man i was waiting for someone to realize that

Share this post


Link to post
Tyockell said:

Ok im using the doom 2 wcf file with WadAuthor beacuse there isent one with icd se but i cant change data in the doom2 data and if i add a new patch to the icd se wad it dosent show up in the game when i run it i cant choose a new patch to use while im running wad author while creating a wad a new level. So im wondering how i can use a totaly new patch??

Good grief, I can hardly understand what you write, you are so disorganized. I'll try to answer again.
The .wcf files, such as doom2.wcf, are used by WadAuthor to reference the proper wad information depending on what game you are editing. There is a doom.wcf, a doom2.wcf, a heretic.wcf, a zdoom.wcf and so forth. So, whatever iwad (doom, doom2, heretic...) this "icd se" wad is designed for, that's the .wcf file to use. You must be using the correct one because when you try to open a wad with WadAuthor, and don't have the proper configuration file (.wcf) selected, WadAuthor will not open the wad; it will show you an error message stating that you need to select another configuration file for this wad.

About patches, simply putting a patch in a wad will not make it available for use unless you put it in "over" an existing patch. In other words, you use an existing standard patch name. Then, whichever textures use that patch name will display your new patch.

You can put Wintex into "edit textures" mode and can see the list of textures. Each texture has one or more patches assigned to it along with information which controls the x,y position of the patches in the texture. Note that some patches are used in more than one texture.

I'm completely mystified by what you mean when you say "can't change data in the doom2 data". Have you read the help files which come with Wintex? I think some of the basics of patch and texture changes are explained there.

Share this post


Link to post

Ok how is it i can make a patch so that its availble to use in WadAuthor. Like when i go to choose a patch for a wall in a sector it wont be there because i cant add to the doom2.wcf. What im doing is running doom2 with Edge 1.27 i take the shortcut for Edge 1.27 and add to the command line file- icd se.wad file- for example mywad.wad and run it. This puts all the extra goodies/edited sprites/sounds into my wad while im playing it. But how do i make a patch avaible to use so i can put it into my wad while using it with the icd se.wad??? I know i can copy and paste all the patches into icd se.wad and edit the existing ones so that they look different while using that wad with the one i created. But how do i make totaly new patches availble to use?

Sorry for the earlyer posts i was in a rush hopefully this may be a bit more clear sorry once again for the trouble.

Share this post


Link to post

You don't need to edit the doom2.wcf file - what you need to do is edit the pnames and texture1 lumps (these contain all the patch and texture names in the wad), as you can add to these without replacing others in the lists.

The only time you need to edit the .wcf file is when you have new sprites (ie. things) in a wad, and you want the new thing names to show up in WA instead of the ones they're replacing. (like I did for my ZDoom episode, as I replaced some scenery things with new ones)

Share this post


Link to post
Biffy said:

I can create a new entry s_end or ss_end, but Wintex does not let me put it where I want it

Are you trying to do this after you press the "select sprites" icon? If so, that's why - for some reason, new patches are only put in the slot you currently have selected when you're viewing everything.

So, click the "select all" button, highlight the top sprite in the list, select Guru Only->New Entry, type in S_START and press enter. Now highlight whatever entry is directly BELOW the bottom sprite (if there's nothing below it, then a lot of fiddling is neccessary), select Guru Only->New Entry, type in S_END and press enter. Voila!

Share this post


Link to post

Thanks Nightmare, I figured that there was a certain step I was missing, one of those special Wintex "features". :)

Share this post


Link to post

Get deepsea. in it, you can load, delete and move files in a wad to wherever you need them to be. The shareware version does this even

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now