SLADE3 freezes randomly in Windows 7

I have Windows 7 Home Edition and I've had slade for awhile. I kept running into issues where it would freeze randomly and it wouldn't even give an error report.

Keep in mind that I have the latest SVN build and the pdb file. I just wanted to know if anyone else is experiencing this same issue, or if there is a way to keep this from happening.

Share this post


Link to post

Run as administratoor, a lot of programs don't work in Windows 7 or Vista if you don't run as administrator.

Share this post


Link to post

Slade doesn't need to be run as administrator. Slayer uses Windows 7 as well for development, by the way.

Also, at the moment, the official version (3.0.1) is more recent than the latest SVN build (r820).

Share this post


Link to post

Slayer uses Windows 7? Awesome!

Oh wait, we're not talking about the band, are we?




But hey, at least you can get Slade 3 to work in Win7...something I can't seem to do.

Share this post


Link to post

SLADE 3 will freeze on me even when running as administrator, Forcing me to do some things in XWE and the other half of things in SLADE 3. If im lucky, SLADE 3 wont freeze while saving. I do run it in Windows 7 but SLADE 3 is the only program ive ever had to run as an admin...

Share this post


Link to post
skaman86 said:

SLADE 3 will freeze on me even when running as administrator

That's because the problem you have isn't related to running as administrator. SLADE 3 doesn't need to have administrator access, and won't do anything with it, so running it as admin is using the wrong remedy for the illness.

I have no idea what would cause these freeze.

Can you try to find possible reasons for these freezes? Next time you have one, can you post the content of the slade3.log, slade3_crash.log and config/slade3.cfg on pastebin? You'll find them either in the directory where you've installed SLADE 3 (for a portable installation) or in %APPDATA%\Slade3 otherwise (just copy paste "%APPDATA%\Slade3" in the address bar of the Windows 7 file manager/explorer and it'll lead you there, but if not the full path is something like C:\Users\<username>\AppData\Roaming\Slade3).

If the crash always happen when a particular file is opened (for example, the mod you are working on), then we may need that file too, to see if we can replicate the bug.

Share this post


Link to post

Yeah, infact im going to be using Slade 3 here in a few minutes. If and when it does freeze, ill be sure to do that.

Also I just checked in C:\Users\<username>\AppData\Roaming\Slade3 all I find there are slade3.cfg, I don't see any kinda crash logs no slade3.log, slade3_crash.log.... I also tried put %APPDATA%\Slade3 in the address bar of the Windows 7 file manager\explorer.. but to no avail.

I must add, When it does freeze for me it says "Slade 3 is not responding" Then it just stays that way and doesnt change. Then ill try to "X" it out and it will tell me windows is looking for the cause of the problem, then it just closes shortly after finding no cause to the problem.

EDIT:Im amazed, Ive used Slade 3 quite a bit lately and im happy to say it hasnt froze... Even when copying over 3,000 entries at once.

Share this post


Link to post

These freezes are still happening and Slade won't even write a report. The freeze usually happens when that windows explorer window pops-up.

For example: User wants to export a flat as PNG "Slade is not responding"

Although I'm not really worried about these crashes anymore because I'll just have to get used to them until slade is fully stable.
Better yet I'll use SlumpEd since its reliable and I can do the important stuff in Slade such as adding patches into texturex and such because it never crashes when I'm dong stuff like that.

Share this post


Link to post

Slade is pretty buggy for me as well. I have windows 7. it will freeze on me if i try to open a file after i've been using the program for more then about a minute. then it freezes up on me at random as well. I just use SLumpEd for the most part.

Share this post


Link to post

Hmm, so does it only lock up when opening some kind of file dialog? Or can it also happen just randomly (ie while just scrolling through entries or editing text, etc)

Share this post


Link to post
SlayeR said:

Hmm, so does it only lock up when opening some kind of file dialog? Or can it also happen just randomly (ie while just scrolling through entries or editing text, etc)


For the most part the crash seems to happen when another window shows up i.e. Import lump from file, export lump, import lump, etc...Sometimes if I'm exporting it never crashes at all until I bring another window into focus then switch back to Slade. Now I can't speak for everyone so, this is how the crashes happen on my OS.

It has never happened while saving or bringing up other tabs in slade.

Share this post


Link to post

I take it that running slade3 in compatibility mode makes no difference?

Share this post


Link to post

Compatibility mode is for running software designed for older versions of Windows. SLADE3 is developed on Windows Vista and Windows 7, so compatibility mode wouldn't solve anything and might even cause problems.


Likewise, running as administrator is not needed. Those are the two approaches that are generally taken as "one-size-fits-all" magic method to make everything works, even when it's not the case. So, just to be clear, you need neither compatibility mode nor running as administrator, any problem you currently have with SLADE 3 will not go away if you try those.

Share this post


Link to post

I use Vista, and out of the total amount of time Ive used SLADE3, it has only frozen once.. Ive used it for almost a year now.

Share this post


Link to post

Recently I found the DRD Team SVN Builds of SLADE 3. I was able to run SLADE 3 r1378 (according to the About dialog) or r1379 (according to the archive name) once without issues on Windows 7 64-bit; but the next time, the welcome page did not appear, the button bar did not show any buttons, and when I hovered the mouse over it, one button background highlighted, then the task started consuming memory until it filled up 2 GB and caused an unhandled exception.

Running it as Administrator worked well.

Share this post


Link to post

^ my reason was solved: It had no access rights to the TEMP folder.

Share this post


Link to post

I'm having a similar problem too with Slade on the audio system. If I play a music track it will eventually crash and close up about a minute later. Not sure why this is happening. I'm using the Chorium soundfont for this but it started crashing about a week ago for me. I re-installed Slade a couple of times now. Anyone know why this might be happening? I'm looking all over the place for a solution.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now