gzdoom monsters limit?

I am building a WAD using GZDoom. I'm using Doom Builder 1 (And I'd love to use Doom Builder 2 but it won't work). I'm using GZDoom config. The problem is, I am working on this big level. I have currently placed lots of monsters. However, I placed some more monsters, saved and tested and they won't appear. I checked the monsters count and it was 249 and i'm assuming that is the limit (hope not). I also have heaps of items in the level.

Another problem. On level 8 no monsters appear - just for that level - even if they are there on the editor. They just won't appear when I play the game. That level is the same GZ doom config.

Can someone figure out what on earth is going on? Maybe I reached the "entities" limit or something?

And I also added health packs and other things and they are not appearing. If it is the thing limit can I increase it?

Share this post


Link to post

There is no hard limit like this. It sounds as if certain flags got off at some point, make sure your monsters are set to appear on whatever skill you're using (right-click on monsters/items that don't appear and look at the checkboxes compared to other monsters/items that do appear; or alternatively, filter things by difficulty, if there is such a feature in DB1).

Just as well, it could be any number of other things. If you upload your wad people will be able to know what's wrong within minutes rather than having to guess. :)

Share this post


Link to post

Anyways, this is also strange. When I try to test the first level I made on doom builder (by pressing "TEST" button, it crashes. But it runs in-game fine. No log whatsoever so I don't know the source of the error. Any ideas?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now