Very odd problem - bullets wont hit enemy

Im in the middle of making a very large map.

No errors come up when I check the level and everything seems perfect in the map. There are two spots in my level where if you try to shoot someone with say the chaingun, it does not hit them until you walk close. However, you can shoot projectiles at them and it works fine. At one spot I am up on some stairs, shooting the chaingun and puffs of smoke are appearing, right infront of me in the middle of the air as if there is an invisible wall there. Anyone know what could possibly be going on? Thanks.

Share this post


Link to post

I've seen this error occur in a lot of very large maps (such as HolyHell) and it might have to do with nodes although I'm not really sure but I think there's a thread about this before so that might help.

Share this post


Link to post

Ill search for a thread...

I have been using glBSP as my node builder with no prior problems. I then tried ZenNode and it didnt work at all.

Share this post


Link to post

i had a similar problem with a map of mine lately... it was caused by either a massive use of actors (it reached 10k actors total or more) and also becouse it was simply too much large to handle for the compiler i used. resizing the map (splitting it in two parts and reducing wasted spaces) and reducing the spawned actors it worked fine.

Share this post


Link to post

Actor = mobj. Pretty much all the things you placed in the map editor (except player starts; and a few port-specific stuff) are actors. In addition, things such as a fired rocket, plasma ball, or fireball, or other projectile is also an actor. Lost soul spawned by a pain elemental? An actor. A bullet puff? An actor. Those annoying arch-vile flames? Actors!

Share this post


Link to post

This sounds like the wall in E3M6 that will block hitscans but lets anything else pass through.

Share this post


Link to post
Dragonsbrethren said:

I was thinking the blockmap bug at first, but that's not really consistent with what you mention about bullet puffs appearing in thin air.

It does sound like a blockmap bug but not that blockmap bug. It sounds like the one that happens in very large levels. It's fixed in new prboom+.

Share this post


Link to post

so i have been making levels for 15 years and have honeslty only ever finished 1 level, temple of skulls, (featured as the picture of the new levels posted every once in while here on doomworld!) im never been a pro, hell I used waded up until a few years ago. but how could I work around it? do you think this will keep on happening from now on? because my level is gigantic, a dream land kinda thing with castles huge trees mountains, ocean floor, pirate ships, lava... and i really want to keep going with this big epic theme

Share this post


Link to post

Only way it's gonna get "fixed" is by playing it with a modern port that addresses the issue. Not much you can do from a mapping standpoint.

Share this post


Link to post

Its happening using GZdoom, with doom in doom format. ive only recently discovered exactly what the other formats were... like I said Im no expert but have a basic understanding.

if I create something in say zdoom in hexen format do you think it would change anything?

Share this post


Link to post

If you switch to ZDoom format, depending on how the architecture is you might be able to split your map into smaller ones and link them together seamlessly with a hub.

Share this post


Link to post
joedotts said:

Its happening using GZdoom, with doom in doom format. ive only recently discovered exactly what the other formats were... like I said Im no expert but have a basic understanding.

if I create something in say zdoom in hexen format do you think it would change anything?


Don't use Hexen format, just use UDMF

Share this post


Link to post

any way I can work around this or fix it? any ideas? it is absolutly destroying my level that is literally years in the making.

Share this post


Link to post

I just dont get why it is doing this... maps like the original Deus Vault is absolutly massive, bigger than mine and more complex and has more monsters.

could i try copying and pasting everything into a new file? maybe its corrupt or something?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now