Sign in to follow this  
Followers 0

SLADE3 Glitching Like Crazy

Ok so I got SLADE3 because, hey! Now I can procrastinate on WADs in a TOUCH SCREEN ENVIRONMENT!!! It worked fine for a while, then all of a sudden the dang thing would crash immediately after loading a graphic. No like, you load up, click an imp sprite or TITLEPIC and SLADE3 has stopped working...

"Ok yeah this will only happen once, right?" That's what I thought. Nope. "Ok, I'll just reinstall!" Still no. Reinstalling didn't do diddley squat.

"Hmm. Maybe it's a Windows 8 compatibility problem? (Although those shouldn't exist on Win7-developed apps...) I'll get a beta build." This was worse. I got this on trying to load a PK3:

Version: 3.1.0 alpha (r1378)
No current action

Stack Trace:
0: [unknown location] ShCompile
1: [unknown location] ShCompile
2: [unknown location] [unknown:237252355]
3: [unknown location] ShCompile
4: [unknown location] [unknown:9653446]
5: [unknown location] [unknown:9650069]
6: [unknown location] [unknown:10416619]
7: [unknown location] [unknown:9645616]
8: [unknown location] [unknown:9349710]
9: [unknown location] [unknown:6209496]
10: [unknown location] [unknown:6195437]
11: [unknown location] [unknown:10246348]
12: [unknown location] [unknown:10132381]
13: [unknown location] [unknown:4934476]
14: [unknown location] [unknown:4944713]
15: [unknown location] [unknown:4675232]
16: [unknown location] [unknown:5851152]
17: [unknown location] [unknown:4945623]
18: [unknown location] [unknown:4946341]
19: [unknown location] [unknown:4716707]
20: [unknown location] [unknown:4913843]
21: [unknown location] [unknown:6505683]
22: [unknown location] [unknown:8214483]
23: [unknown location] [unknown:8191227]
24: [unknown location] [unknown:8186636]
25: [unknown location] [unknown:7034820]
26: [unknown location] [unknown:7069520]
27: [unknown location] [unknown:7023318]
28: [unknown location] GetKeyboardLayout
29: [unknown location] DispatchMessageW
30: [unknown location] [unknown:6808691]
31: [unknown location] [unknown:6513416]
32: [unknown location] [unknown:6876128]
33: [unknown location] [unknown:6651893]
34: [unknown location] [unknown:7375231]
35: [unknown location] [unknown:4678186]
36: [unknown location] BaseThreadInitThunk
37: [unknown location] RtlInitializeExceptionChain
38: [unknown location] RtlInitializeContext
WHAT in the world is going on? ANY ideas??

Share this post


Link to post

This sounds like a system problem more than anything. What does the log file say? (should be in the same folder as the .exe)

Share this post


Link to post

There are no files under C:\Program Files (x86)\SLADE3 or C:\Users\Orangestar\AppData\Roaming\SLADE3 that even remotely look like a log file. Just a help file in the one and a config file in the other.

Share this post


Link to post

UPDATE: Found a few SLADE3 logs in the virtual store. (They STILL haven't gotten rid of that?) Here's SLADE3.LOG

9:48:27 PM: SLADE - It's a Doom Editor
9:48:27 PM: Version 3.0.2
9:48:27 PM: Written by Simon Judd, 2008-2013
9:48:27 PM: Compiled with wxWidgets 2.9.1
9:48:27 PM: --------------------------------
9:48:27 PM: Loading configuration
9:48:27 PM: Loading resources
9:48:27 PM: Loading icons
9:48:28 PM: Loading entry types
9:48:28 PM: Loading text languages
9:48:28 PM: Loading text style sets
9:48:28 PM: Loading base resource
9:48:29 PM: Opening archive C:\Users\Orangestar\Documents\DOOM_WADS\PWADS\HD\voxel_items.wad
9:48:30 PM: SLADE Initialisation OK
And here's SLADE3_CRASH.LOG
Version: 3.1.0 alpha (r1378)
No current action

Stack Trace:
0: [unknown location] ShCompile
1: [unknown location] ShCompile
2: [unknown location] [unknown:237252355]
3: [unknown location] ShCompile
4: [unknown location] [unknown:9653446]
5: [unknown location] [unknown:9650069]
6: [unknown location] [unknown:10416619]
7: [unknown location] [unknown:9645616]
8: [unknown location] [unknown:9349710]
9: [unknown location] [unknown:6209496]
10: [unknown location] [unknown:6195437]
11: [unknown location] [unknown:10246348]
12: [unknown location] [unknown:10132381]
13: [unknown location] [unknown:4934476]
14: [unknown location] [unknown:4944713]
15: [unknown location] [unknown:4675232]
16: [unknown location] [unknown:5851152]
17: [unknown location] [unknown:4945623]
18: [unknown location] [unknown:4946341]
19: [unknown location] [unknown:4716707]
20: [unknown location] [unknown:4913843]
21: [unknown location] [unknown:6505683]
22: [unknown location] [unknown:8214483]
23: [unknown location] [unknown:8191227]
24: [unknown location] [unknown:8186636]
25: [unknown location] [unknown:7034820]
26: [unknown location] [unknown:7069520]
27: [unknown location] [unknown:7023318]
28: [unknown location] GetKeyboardLayout
29: [unknown location] DispatchMessageW
30: [unknown location] [unknown:6808691]
31: [unknown location] [unknown:6513416]
32: [unknown location] [unknown:6876128]
33: [unknown location] [unknown:6651893]
34: [unknown location] [unknown:7375231]
35: [unknown location] [unknown:4678186]
36: [unknown location] BaseThreadInitThunk
37: [unknown location] RtlInitializeExceptionChain
38: [unknown location] RtlInitializeContext
Hm, seems to be the same thing the beta spit out at me.

Share this post


Link to post

Do you have the pdb file in the same folder as slade.exe? If not, download Slade-r1379-pdb.7z from http://svn.drdteam.org/slade and extract it to the slade (svn build) folder. This should make the stack trace a bit more useful (hopefully), rather than just being full of 'unknown location'

Share this post


Link to post

I downloaded the PDB and moved SLADE3 to it's own nice little folder in the Documents. Nothing like a folder owned by yourself to keep a program happy. I load up a nice little copy of DOOM2.WAD I happened to have made and...

Version: 3.1.0 alpha (r1378)
No current action

Stack Trace:
0: [unknown location] ShCompile
1: [unknown location] ShCompile
2: [unknown location] [unknown:189607683]
3: [unknown location] ShCompile
4: [unknown location] sf::priv::WglContext::WglContext
5: [unknown location] sf::priv::GlContext::globalInit
6: [unknown location] sf::GlResource::GlResource
7: [unknown location] sf::Window::Window
8: [unknown location] sf::RenderWindow::RenderWindow
9: (d:\jeux\doom\source\slade3\src\oglcanvas.cpp:57) OGLCanvas::OGLCanvas
10: (d:\jeux\doom\source\slade3\src\gfxcanvas.cpp:53) GfxCanvas::GfxCanvas
11: (d:\jeux\doom\source\slade3\src\gfxentrypanel.cpp:308) GfxEntryPanel::GfxEntryPanel
12: (d:\jeux\doom\source\slade3\src\archivepanel.cpp:191) ArchivePanel::ArchivePanel
13: (d:\jeux\doom\source\slade3\src\archivemanagerpanel.cpp:526) ArchiveManagerPanel::openTab
14: (d:\jeux\doom\source\slade3\src\archivemanagerpanel.cpp:1091) ArchiveManagerPanel::onAnnouncement
15: (d:\jeux\doom\source\slade3\src\listenerannouncer.cpp:133) Announcer::announce
16: (d:\jeux\doom\source\slade3\src\archivemanager.cpp:254) ArchiveManager::openArchive
17: (d:\jeux\doom\source\slade3\src\archivemanagerpanel.cpp:741) ArchiveManagerPanel::openFile
18: (d:\jeux\doom\source\slade3\src\archivemanagerpanel.cpp:763) ArchiveManagerPanel::openFiles
19: (d:\jeux\doom\source\slade3\src\archivemanagerpanel.cpp:1264) ArchiveManagerPanel::handleAction
20: (d:\jeux\doom\source\slade3\src\mainapp.cpp:874) MainApp::doAction
21: (d:\jeux\doom\source\slade3\src\mainwindow.cpp:671) MainWindow::onHTMLLinkClicked
22: (d:\applications\progra\wxwidgets\src\common\appbase.cpp:596) wxAppConsoleBase::HandleEvent
23: (d:\applications\progra\wxwidgets\src\common\appbase.cpp:607) wxAppConsoleBase::CallEventHandler
24: (d:\applications\progra\wxwidgets\src\common\event.cpp:1333) wxEvtHandler::ProcessEventIfMatchesId
25: (d:\applications\progra\wxwidgets\src\common\event.cpp:1673) wxEvtHandler::SearchDynamicEventTable
26: (d:\applications\progra\wxwidgets\src\common\event.cpp:1428) wxEvtHandler::ProcessEvent
27: (d:\applications\progra\wxwidgets\src\generic\scrlwing.cpp:221) wxScrollHelperEvtHandler::ProcessEvent
28: (d:\applications\progra\wxwidgets\src\html\htmlwin.cpp:1070) wxHtmlWindow::OnLinkClicked
29: (d:\applications\progra\wxwidgets\src\html\htmlcell.cpp:183) wxHtmlCell::ProcessMouseClick
30: (d:\applications\progra\wxwidgets\src\html\htmlwin.cpp:253) wxHtmlWindowMouseHelper::OnCellClicked
31: (d:\applications\progra\wxwidgets\src\html\htmlwin.cpp:189) wxHtmlWindowMouseHelper::HandleMouseClick
32: (d:\applications\progra\wxwidgets\src\html\htmlwin.cpp:1286) wxHtmlWindow::OnMouseUp
33: (d:\applications\progra\wxwidgets\src\common\appbase.cpp:596) wxAppConsoleBase::HandleEvent
34: (d:\applications\progra\wxwidgets\src\common\appbase.cpp:607) wxAppConsoleBase::CallEventHandler
35: (d:\applications\progra\wxwidgets\src\common\event.cpp:1333) wxEvtHandler::ProcessEventIfMatchesId
36: (d:\applications\progra\wxwidgets\src\common\event.cpp:939) wxEventHashTable::HandleEvent
37: (d:\applications\progra\wxwidgets\src\common\event.cpp:1428) wxEvtHandler::ProcessEvent
38: (d:\applications\progra\wxwidgets\src\generic\scrlwing.cpp:221) wxScrollHelperEvtHandler::ProcessEvent
39: (d:\applications\progra\wxwidgets\src\common\event.cpp:1569) wxEvtHandler::SafelyProcessEvent
40: (d:\applications\progra\wxwidgets\src\msw\window.cpp:5461) wxWindow::HandleMouseEvent
41: (d:\applications\progra\wxwidgets\src\msw\window.cpp:2998) wxWindow::MSWHandleMessage
42: (d:\applications\progra\wxwidgets\src\msw\window.cpp:3613) wxWindow::MSWWindowProc
43: (d:\applications\progra\wxwidgets\include\wx\scrolwin.h:395) wxScrolled<wxPanel>::MSWWindowProc
44: (d:\applications\progra\wxwidgets\src\msw\window.cpp:2711) wxWndProc
45: [unknown location] gapfnScSendMessage
46: [unknown location] gapfnScSendMessage
47: [unknown location] GetKeyboardLayout
48: [unknown location] DispatchMessageW
49: (d:\applications\progra\wxwidgets\src\msw\evtloop.cpp:273) wxGUIEventLoop::ProcessMessage
50: (d:\applications\progra\wxwidgets\src\msw\evtloop.cpp:335) wxGUIEventLoop::Dispatch
51: (d:\applications\progra\wxwidgets\src\common\evtloopcmn.cpp:159) wxEventLoopManual::Run
52: (d:\applications\progra\wxwidgets\src\common\appbase.cpp:318) wxAppConsoleBase::MainLoop
53: (d:\applications\progra\wxwidgets\src\common\init.cpp:472) wxEntryReal
54: (d:\applications\progra\wxwidgets\src\msw\main.cpp:189) wxEntry
55: (d:\applications\progra\wxwidgets\src\msw\main.cpp:414) wxEntry
56: (d:\jeux\doom\source\slade3\src\mainapp.cpp:261) WinMain
57: (f:\rtm\vctools\crt_bld\self_x86\crt\src\crtexe.c:578) __tmainCRTStartup
58: [unknown location] BaseThreadInitThunk
59: [unknown location] RtlInitializeExceptionChain
60: [unknown location] RtlInitializeExceptionChain
Well, this is new.

For all I know (and I don't know a lot) this probably could be a system problem. I'm seeing the phrase "GL" in there, and these damn Intel beta drivers can't do anything that does with OpenGL. That includes GZDoom, Minecraft, the works.

Share this post


Link to post

Yes, SLADE 3 uses OpenGL to display, well, anything that's not a UI element. (Images, map view, map editor, etc. are all handled with OpenGL.)

Share this post


Link to post
Gez said:

Yes, SLADE 3 uses OpenGL to display, well, anything that's not a UI element. (Images, map view, map editor, etc. are all handled with OpenGL.)

I kinda wonder why… They're just 2D images, often small.

Share this post


Link to post

Because when we have OpenGL code, it's simpler to use it; because it makes it easier to do stuff like the tiled backdrop, border framing around images, color changes for stuff that is highlighted or (in the texture editor) part of a patch outside of the texture; because it allows to perform simply the various types of blending needed for preview of ZDoom textures; and so on.

Share this post


Link to post

The weirdest thing that I forgot to mention was that I had used Slade on this computer before. It just all of a sudden stopped working like this. Oh well, one more reason to dual boot with Ubuntu, I guess. Thanks for the help, guys!

Share this post


Link to post
Orangestar said:

The weirdest thing that I forgot to mention was that I had used Slade on this computer before. It just all of a sudden stopped working like this.

Same thing here. For example (and this is just one of the instances where it crashes), I used to be able to compile ACS scripts with no trouble, but now it just crashes every single time I do so.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0