'Level Entering' Screen trouble

Recently I've been working on a doom 2 wad, it's got 2 levels in it so far, and i'm using a MAPINFO lump to tell ZDoom what name to put on the automap and intermission screen but for some reason, after I finish the 1st level and get to the intermissions screen, zdoom skips the 'level entering' screen and goes straight to the second level. What am I doing wrong?

This is a copy of my MAPINFO lump if it helps:

map MAP01 "The Vault"
{
music = "D_RUNNIN"
next = "MAP02"
}

map MAP02 "Gateway"
{
music = "D_STALKS"
next = "MAP03"
}

Thanks in advance

Share this post


Link to post

Add this before all of that:

clearepisodes

And add this in your brackets so your sky doesn't disappear:

sky1 = "RSKY1", 0 (or whatever your sky's name is)

I'm not sure if this will fix your particular problem, but should be done anyway.

Share this post


Link to post

clearepisodes isn't needed for Doom II... And you definitely shouldn't use it if you do not define your own episodes afterwards!

If you want to have "level entering" screens, you need to define an enterpic for each level.

Share this post


Link to post
Gez said:

clearepisodes isn't needed for Doom II... And you definitely shouldn't use it if you do not define your own episodes afterwards!

If you want to have "level entering" screens, you need to define an enterpic for each level.


Huh, I've been horribly misinformed. I could never get custom map info to work until I added that. But now that I've removed it, it still works. Maybe I goes homes and reevaluates my life.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now