ZDL possible bug and dumb suggestions.

A few times while recording demos I have found that ZDL will launch the specified port (usually PrBoom+) and yet when attempting to move, I can't, as if the window wasn't active. Of course, this can be fixed by simply clicking (also firing), but on some of the occasions that this has happened, I will close PrBoom+ to find that ZDL has also closed, even though the close on launch option is unchecked. I don't click between "launch" and the game loading, so this isn't the problem.

My dumb suggestion #1 is that the -playdemo parameter gets it's own section out of the command line. If it's possible to implement it, have the usual Browse button so the user can select a demo from anywhere on the hard drive(s). While I've half solved this by setting LMPs to automatically open with PrBoom+, sometimes the IWAD is wrong. This also causes more kerfuffle when working with PWADs.

My other dumb suggestion is that the number of windows that ZDL can launch at any one time is limited to 1. No-one needs more than 1 anyway, and although it's my own fault for acting stupid due to failed speedruns, 20-30 PrBooms isn't much fun to sort out.

Share this post


Link to post

For bugs and/or improvements, I would recommend speaking to Qbasicer he can be found at the ZDoom forums or under the IRC channel #ZDoom on esper.net. ZDL hasn't been updated in about a year or so as far as I can tell (unless he's released a few cheeky one's that I haven't known about).

Share this post


Link to post

qZDL is Qbasicers re-write of ZDL if I remember correctly. He posted last year on ZDoom a re-write of ZDL called qZDL, again this is just from memory so I could be wrong.

Share this post


Link to post

It'd be nice if it could remember what the last folder I loaded a file from was instead of always jumping back to the folder ZDL is in.

Share this post


Link to post

Eris, this may interest you, I think Q is going to start continuing work on ZDL again.

Share this post


Link to post

Ah. This is good to see.
I don't have much intention of registering at ZDoom, since I'll probably never go there, but it might be worth forwarding this thread to him.

Share this post


Link to post

Q here,
Unfortunately I did a half migration of the ZDL website to another host. I put the database in read-only mode and the wiki eventually just didn't work. It's all fixed up now though.

Yes I'm trying to gather some recommendations for a 3.2.3.0 release, but I currently have no ETA on a release date.

Bug list:
Limit total ZDL processes to 1
https://bugs.vectec.net/show_bug.cgi?id=20

Give -playdemo it's own configuration section
https://bugs.vectec.net/show_bug.cgi?id=21

ZDL Might be Automatically Closing When it Shouldn'
https://bugs.vectec.net/show_bug.cgi?id=22

Eris, for the last one, I need a log to understand what's going on during launch. Please follow the instructions here: http://zdl.vectec.net/wiki/Support

Ideally, the best thing would be to create an account on the bugzilla, but you really don't have to. You can pastebin the output and PM me a link somewhere and I can use that.

Share this post


Link to post

Late response, but I'll check if my copy of ZDL is up-to-date. It could be I'm just using an out-of-date version.

EDIT: It's 3.2.2.2, which seems to be the most up-to-date version?

Share this post


Link to post
Shadow Hog said:

Late response, but I'll check if my copy of ZDL is up-to-date. It could be I'm just using an out-of-date version.

EDIT: It's 3.2.2.2, which seems to be the most up-to-date version?

Yep, 3.2.2.2 is the most recent version. Please follow the steps I gave to Eris to help me track down the issue.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now