No Strife sprites (things) in Doom Builder

I've tried Strife modding Strife today - and the problem is the sprites just don't appear in the game world. It can be already seen in the Doom Builder (empty boxes where they should be displayed) - but I thought it's just a visual issue. When running test they simply don't exist like they were not put there.

There is no such issue while working with the original Doom WAD.

Strife alone works just fine.

Share this post


Link to post

1. Check if the sprites are between SS_START and SS_END markers.
2. Check the format of sprites. I saw that there's a format named "Strife", maybe you need to use it. Or maybe you mustn't use it. I don't know, never modded for Strife.

EDIT: Just now I realised - I probably misunderstood completely, I assumed you're using custom sprites, sorry if you mean otherwise.

Share this post


Link to post

I was trying to use default Strife sprites (npcs, weapon, decoration...).

As I mentioned, they do appear in game (Strife run with zDoom and Strife alone).

For what I remember, I had the same problem when I was using WAD file from the original CD (currently I'm using one downloaded from the
Internet).

edit:
Since sprites work with in game but not in tests I changed the thread name to be more descriptive.
I'll try to run the modified WAD with zDoom and see does it work.
Even if it will do, that won't solve the testing problem.

Share this post


Link to post

Probably just a question of whoever did the configuration file being lazy and not looking up sprite names for the various actors.

Have you tried in GZDB or plain old DB2? They don't have the same config files.

Share this post


Link to post

I am pretty sure he's saying the things he placed don't show up in the game, either.

To avoid confusion, if you mean items that are placed into the map, use the word "things" and not "sprites." In DOOM parlance, a moving or stationary object is a "thing", while the graphic it displays is a sprite.

Share this post


Link to post

"Have you tried in GZDB or plain old DB2? They don't have the same config files".
DB2

I tried now to switch configuration from zDoom's Strife in Hexen format I was using to simply Strife. And: no things present in the visual mode - but things present in test.

Still, the thing is, I'd like to use all features zDoom provides. Well, at least some of them.

Share this post


Link to post

Check the flags on the things. Most importantly, are they flagged to appear at any skill at all?

Share this post


Link to post
Inq said:

I've tried Strife modding Strife today - and the problem is the sprites just don't appear in the game world. It can be already seen in the Doom Builder (empty boxes where they should be displayed) - but I thought it's just a visual issue. When running test they simply don't exist like they were not put there.

There is no such issue while working with the original Doom WAD.

Strife alone works just fine.


As Gez already hinted at, it has to do with somebody having to go through some of the config files and adding in the sprite names, etc.

For example, in the Strife config file Strife_things.cfg, you have this:

3005
	{
		title = "Crusader";
		width = 40;
	}
change it to this:
3005
	{
		title = "Crusader";
		width = 40;
		sprite = "ROB2A2";
		height = 64;
	}
and the Crusader sprite will be visible in Doombuilder2 or GZDoombuilder.

Share this post


Link to post
Inq said:

(but then - why start marker works without it?)


Player starts are handled differently from all other things; and notably they ignore skill flags as well as single/multiplayer flags.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now