Sign in to follow this  
Followers 0

WR teleport only monsters not working on vanilla

When I use doombuilder I set doom configuration, but when I test my maps on doom.exe some linedef actions seem not to work (eg: 126 WR teleport monsters only or some W1 door open fast). Is there a way to make them work or there is an available list of linedef actions which do not work on vanilla?

Share this post


Link to post

It's simple. You are running it with shareware Doom. Shareware Doom was released in 1993. Some additional linedef actions appeared in Doom 2 and later Ultimate Doom. What you are looking for is full version of Ultimate Doom (version 1.9), or a sourceport that allows you to use shareware Doom as an IWAD, but acts like the 1.9 version. You don't have to care about players who don't own full version when designing your maps. Also note that Chocolate Doom is actually exactly like vanilla Doom, so for testing and bug-finding purposes, you can use it without worrying that you may miss some bugs.

Share this post


Link to post

If he were running it with Shareware Doom, he would not be able to load his file at all.

Share this post


Link to post
scifista42 said:

It's simple. You are running it with shareware Doom. Shareware Doom was released in 1993. Some additional linedef actions appeared in Doom 2 and later Ultimate Doom. What you are looking for is full version of Ultimate Doom (version 1.9), or a sourceport that allows you to use shareware Doom as an IWAD, but acts like the 1.9 version. You don't have to care about players who don't own full version when designing your maps. Also note that Chocolate Doom is actually exactly like vanilla Doom, so for testing and bug-finding purposes, you can use it without worrying that you may miss some bugs.


I see, the issue is that I don't know how to load wads with chocolate doom, (don't know how to imput the commands because the program forbids me to be open from dosbox) so I'm testing my map with doom.exe on dosbox which allows me to input the command -file ***.wad. I've loaded the map using the ultimate doom Iwad and the linedef still doesn't work, disturbing the gameplay drammatically as a result.
Maybe this is a minor issue since almost every maptester I run into uses prboom+.

Share this post


Link to post

Not Ultimate Doom IWAD, you need Ultimate Doom version of the .exe.

Also running PWADs with Chocolate Doom is simple and I described it in your thread, just put that text I gave you in a text file, then change its file extension to .bat and double click it, and Choco should run your PWAD.

Share this post


Link to post
scifista42 said:

Not Ultimate Doom IWAD, you need Ultimate Doom version of the .exe.

Also running PWADs with Chocolate Doom is simple and I described it in your thread, just put that text I gave you in a text file, then change its file extension to .bat and double click it, and Choco should run your PWAD.

Yes, the old .exe version, I thought about it too. Thanks, I'll do it with chocolate doom!

Edit:
Done! it works perfectly with chocolate doom, no bugs, thanks again!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0