Sarge
User Control Panel | Member List | FAQ | Privacy Policy | Blogs | Search Forums | Forums Home
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > more EDGE questions
 
Author
All times are GMT. The time now is 07:46. Post New Thread    Post A Reply
deathz0r
Bitch fuckin' stole me chaingun!


Posts: 3621
Registered: 01-01


a couple of them....

1. this is very weird, but i did this stuff in the UAC Ress DDFs...

attacks.ddf
^^^^^^^^^^^
[MARINE_BFG2]
ATTACKTYPE=SPRAY;
HEIGHT=16;
RADIUS=20;
TRANSLUCENCY=0.5;
DAMAGE_MULTI=2;
DAMAGE=25;
ATTACKRANGE=1024;
PROJECTILE_SPECIAL=NOGRAVITY;

STATES(SPAWN)=BFE2:A:8:BRIGHT:NOTHING,
BFE2:B:8:BRIGHT:NOTHING,
BFE2:C:8:BRIGHT:NOTHING,
BFE2:D:8:BRIGHT:NOTHING,
#REMOVE;

[MARINE_BFG]
ATTACKTYPE=PROJECTILE;
HEIGHT=8;
RADIUS=13;
SPEED=20;
DAMAGE_MULTI=2;
DAMAGE_RANGE=100;
ATTEMPT_SOUND=BFG;
DEATH_SOUND=rxplod;
ATTACK_HEIGHT=32;
TRANSLUCENCY=0.66;
SPARE_ATTACK=MARINE_BFG2;
ATTACK_SPECIAL=KILL_FAILED_SPAWN;
PROJECTILE_SPECIAL=NOBLOCKMAP,MISSILE,DROPOFF,NOGRAVITY;

STATES(IDLE)=BFS1:A:4:BRIGHT:NOTHING,
BFS1:B:4:BRIGHT:NOTHING;

STATES(DEATH)=BFE1:A:8:BRIGHT:NOTHING,
BFE1:B:8:BRIGHT:NOTHING,
BFE1:C:8:BRIGHT:SPARE_ATTACK,
BFE1:D:8:BRIGHT:NOTHING,
BFE1:E:8:BRIGHT:NOTHING,
BFE1:F:8:BRIGHT:NOTHING,
#REMOVE;


things.ddf
^^^^^^^^^^
[SPACE_MARINE_BFG:2924]
SPAWNHEALTH=190;
REACTION_TIME=0.23;
RADIUS=20;
HEIGHT=56;
SPEED=12;
MASS=100;
CASTORDER=22;
PAINCHANCE=67%;
PALETTE_REMAP=PLAYER_GOLD;
SPECIAL=COUNT_AS_KILL,SOLID,CLIMBABLE,SHOOTABLE,NO_GRUDGE;
MINATTACK_CHANCE=22%;
BLOOD=BLOOD;
RESPAWN_EFFECT=RESPAWN_FLASH;
ACTIVE_SOUND="POSACT";
DEATH_SOUND="PLDETH?";
PAIN_SOUND=PLPAIN;
SIGHTING_SOUND=MARSIT;
OVERKILL_SOUND="SLOP";
DROPITEM=CELL_BOX;
RANGE_ATTACK=MARINE_BFG;

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Have a good read of it, because for some odd reason, they seem to shoot each other. Evidence seen here.
Does anyone know how to fix it without having to set "NEVERATTACKED" in things.ddf?

2. With the water, it seems to only have one thin layer, height of 0, so it's impossible to make a realistic-looking waterfall. Will this be fixed in 1.25?

Old Post Jul 7 2001 00:16 #
deathz0r is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Fanatic
Lost Soul


Posts: N/A


1. is there a problem with the marines, or something else?

2. you have to use a thick liquid extrafloor for waterfalls, the QDOOM public test has these for QD02 near the start area.

Old Post Jul 7 2001 01:45 #
IP || Edit || Quote
deathz0r
Bitch fuckin' stole me chaingun!


Posts: 3621
Registered: 01-01


1. yeah, but it's only those certain marines. The ones with other weapons (eg. shotgun) don't shoot each other (that have the same weapon).

2. ok.

Old Post Jul 7 2001 02:13 #
deathz0r is offline || Blog || PM || Post History || Add Buddy IP || Edit || Quote
Fanatic
Lost Soul


Posts: N/A


If certain marines are misbehaving, I would suspect something is wrong with their entries. Like a SIDE issue (creates teams).

Not sure what the weapon would have to do with it, unless there's a possible bug with the spreader code causing weird targets to appear.

Old Post Jul 7 2001 03:49 #
IP || Edit || Quote
All times are GMT. The time now is 07:46. Post New Thread    Post A Reply
 
Doomworld Forums : Powered by vBulletin version 2.2.5 Doomworld Forums > Classic Doom > Doom Editing > more EDGE questions

Show Printable Version | Email this Page | Subscribe to this Thread

 

Forum Rules:
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
HTML code is OFF
vB code is ON
Smilies are OFF
[IMG] code is ON
 

< Contact Us - Doomworld >

Powered by vBulletin
Copyright vBulletin Solutions, Inc.