TAS (tools-assisted) demos

what do you see thats so unusual on map08 lol, all i was doing was bouncing around in the sector waiting for it to lower all the way

Share this post


Link to post

So i was planning to fix my old plutonia movie a little bit (map16 and map25 for example), but i dont want to redo anything except for these maps. Is there any way to roll the random number generator to the same number at the start of the next map? I've already fixed map25, but the movie quickly desyncs at map26, so the numbers are not right. Is there any tool that shows your current position in RNG table? dre2 seems to show some "rand" thingie, but it simply increments by 1 with each tic (except for intermission screens), and not reacting at my actions. Or am i missing something there?

Share this post


Link to post

Dre2 doesn't show the correct rnd. It's possible to roll it as I did it myself in map01 using my own dre I hacked together for my built run. It may not be easy, though.

Share this post


Link to post

could you share this hacked dre or is it super-secret? :)

Share this post


Link to post

jongo, do you plan to add some random shoots / movements at end of newest map25 to make prndindex at start of map26 the same as before?

Share this post


Link to post

yea, i was going to use chaingun on my way to (hopefully) quickly get the index i want.

Share this post


Link to post

Also while editing 30pl1337.lmp i noticed a weird thing. It happens at tic 23309: right after entering the last teleporter in map25 i move a little bit, which allows me to pick up plasmagun (which is placed at the spot where i get teleported to). I don't have a plasmagun by that point, so this starts a weapon changing animation, and i can abuse it to switch to rocket launcher instead. I still can't move manually though and have to wait a few tics before being able to move / turn, and no one shoots me too. Is this phenomenon caused by final doom buggy teleporter behaviour and can it be manipulated? I really need these few tics to get under 12 seconds in this map, but i always end up standing still after teleporting now :/

Share this post


Link to post

Is this phenomenon caused by final doom buggy teleporter behaviour


No, I first encountered it in doom2 map15. I don't know what causes it, though. Check your pm btw.

Share this post


Link to post

Real World (sorry if RW demos thread exists - I couldn't find it, so I post my RW demo here) map09 UV-Speed in 0:04 (TAS), CL 2, built with DRE 2.
PS: Sorry, I posted in wrong thread :( Can't delete this post. Please, move this post into "Miscellaneous TAS demos" thread.

rw09-004.zip

Share this post


Link to post

jongo, do you mean the phenomenon when you teleport and are moving immediately after that, i.e. the teleporter doesn't hold you? I had this happening quite a few times recently in Equinox.wad, and only on certain teleporters. I suspected this may have something to do with the player being next to (or getting stuck at) a monster just before teleporting, but now I'm in doubt, because sometimes this also happens without any monsters nearby.

If you are willing to investigate, I can tell specifically at which teleporters I encountered this behavior, and I have one saved demo (though I had this happen numerous times). All those teleporters do have something in common - the player enters them westward and teleporting lines touch 1-sided lines. But I'm not sure if that is important - I tried to make a test wad based on this observation, and I could not reproduce this behavior.

Share this post


Link to post

Something like that, but i move only for 1 tic and do not have any control over the movement, and the distance i travel in that tic isn't big. I still have to wait standard ~15 tics before being able to move at will.
Actually, i was wrong in my previous post, the tic to look at in my demo is 23308, not 23309. The correct teleport destination is (1504,992), but i somehow get translated to (1504.888687,1000.307648).
Also it's not your typical situation where you get shot right after teleporting, which eliminates the teleporter wait. Like in map03 in 10uv-256.lmp for example.
I'll try to test it, but i guess it would be more reasonable to ask coders for help :D

Share this post


Link to post

moar spamming by me!
This time it's Ultimate Doom demo. Inspired by entryway's this post, i decided to look at how many tics i could save from e4m1. It appeared that another second is shaveable, with the cost of using jerky turns. The demo is actually barely watchable imo and entryway's one looks more impressive and flashy. So now i'm not sure whether i should continue making e4uv or lay it off and leave it to more skilled builders out there.
Still happy to crack another second :)
EDIT: i decided against continuing the movie, at least for now. I'll keep working on d2reloaded.

e4m1-013.zip

Share this post


Link to post

Real World is losing its blood.
RW map01 UV-Speed (also pacifist) in 0:04. Built with DRE 2, CL 2.
Uhm, why not to make the whole-wad UV-Speed movie?..

rw01-004.zip

Share this post


Link to post

yeah, i got lazy lately and went full-DRE. Combining prboom and dre could yield same results and smoother demo, but my workflow is very inefficient, so maybe it's a bad tip after all.
Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?

Share this post


Link to post
jongo said:

yeah, i got lazy lately and went full-DRE. Combining prboom and dre could yield same results and smoother demo, but my workflow is very inefficient, so maybe it's a bad tip after all.
Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?


problem is that i cannot run DRE on my system at all, i have tried before a while ago for hours without success, dunnio why it wont run. but i would like to run it because i know it produces better results... in fact, what is the concept behind DRE ? how does it even work and what does it let you do. i just utilize all of the built in TAS tools that come with prboom in my demo, thats using gamespeed 20, enabling permenant strafe50, enabling strafe50 on turns, and of course using segmenting =) i do hate how long it takes to load the later maps using recordfromto...

Share this post


Link to post
jongo said:

Actually, i was always curious about others' workflows (and i think this question fits the topic loosely anyway), namely Akse and Andy Olivera, and others as well of course. Could you guys tell a bit about your approach to producing demos?

I start by creating an empty demo (a few seconds) with PRBoom+ which I then load in to DRE. The only other thing PRBoom+ gets used for is playback if I need to track how much damage I'm doing. When doing that, I just save the demo, suspend DRE, tab to the command line, playback the demo, then tab back to DRE to continue. That's pretty much it, in terms of workflow.

Oh, when I'm done with the demo I'll use -recordfromto to remove the garbage at the end that gets built up over time, then tack on some WT tics with DRE.

Share this post


Link to post
odysseyofnoises said:

problem is that i cannot run DRE on my system at all, i have tried before a while ago for hours without success, dunnio why it wont run. but i would like to run it because i know it produces better results.....

Try xepop's XDRE. It's based on Prboom-Plus 2.5.1.3, so it should run on every system. Link can be found in that thread:
http://www.doomworld.com/vb/doom-speed-demos/59676-doom2-4-player-built-nomonster-full-run/
Find the download link below.

Share this post


Link to post

It's somewhere at the bottom of the first page and is not highlighted, here it is:
users.jyu.fi/~jomihaka/xdre.zip

Share this post


Link to post

how do i even use xdre... all it does when i launch it is pull up a black window and crash everything

Share this post


Link to post
odysseyofnoises said:

how do i even use xdre... all it does when i launch it is pull up a black window and crash everything

I probably know what's the matter. Did you read readme.txt? There is many useful info. Really. :)

Share this post


Link to post

There's 1.20 version for xdre: http://users.jyu.fi/~jomihaka/xdre.zip

Added button to unset savepoint for easier check for desyncs. Also fixed brainfart in bruteforce. Now it should actually work. Unfortunately, I don't have time nor willingness to look for prboom_plus' savegame bugs, which you are experiencing.

Share this post


Link to post

I don't know :p I used it, but I couldn't get any results.
Probably simple tricks, like glides (for example, jongo used brute force to make map25 glide in his 30pl1316) or some successful wallruns. I've just asked xepop in PM, just for interest. :D
BTW, going to test new version :3
I'm [probably] pro in these DREs and I can do [probably] every trick. Let's try...

Share this post


Link to post
This topic is now closed to further replies.