Sign in to follow this  
Followers 0

Longdays.wad "Silent Pacifist" speedrun

Stimulated by Jodwin, I tried my own approach at at Long Days, the latest nuts.wad brainchild.

Jodwin tried UV-MAX and plain pacifist runs, which clocked in at about 8:40 and 6:40 each (more or less).

I decided to take a "Silent pacifist", that is, pacifist with a twist: not firing a single bullet or punch during the whole level.

This leads to certain very particular travel patterns, as monsters need to be awakened by your presence, and you need to shepherd them and cause infighting more actively, as large portions may remain unawakened unless you go there and face them.

Certain parts are made harder by this, since you need to run around a lot and face monsters personally, others are arguably made easier (not a single cacodemon appears!)

In any case, it clocked in at 6:42 with 96% kills, 28% items (I think) and 100% secrets. Enjoy!

Plays on latest PrBoom+ 2.0.5.2 with -complevel 9

My b0x is an Athlon64 3200+ with 1 GB RAM and an Ati 9600XT with 256 RAM, in case you wondered.

maes_longdays_silent.zip

Share this post


Link to post

heh, 7- is good, but not for 96%. Not so hard to kill ~8800 from 8888 for 6:00. But you need additional 2 minutes to kill the rest! Try to use the latest feature from GLboom-plus 2.5.0.3.test. Press Numpad/ once or twice during playing. It can help :)

Anyway, it was interesting to see. My time for 100% is ~8:20

Share this post


Link to post

Keep in mind that this is not a normal pacifist run, but a "silent pacifist", which means I'm not firing at all and certain monsters are not awakened (most notably, the cacodemons). This also alters the gameplay quite a bit, as monsters need to see you to start moving and you risk blocking your way in several spots.

I was quite surprised to see a 96% count (same as Jodwin's pacifist run with firing to awake the monsters, though), so yeah, 100% should be possible even in this mode (with some help from the archies) but I had lost quite a lot of time and didn't stick around to raise the kills further.

Notice how in many occasions I tried to "stick around" in certain places in order to coerce the cybies to bombard the angry mob. Also, monsters that survive infighting are not regularly re-awakened by my firing. In order to have a chance to escape the central room, the arena must also be previously cleaned up enough (a roaming cybie helps, too many revenants do not).

Share this post


Link to post

I get no sound of any kind (either music or sound) on the level in question, map01. The other maps have sound/music as normal. Is this expected? The text file says there is music included. I'm using glboom+.

Share this post


Link to post
entryway said:

Try to use the latest feature from GLboom-plus 2.5.0.3.test. Press Numpad/ once or twice during playing. It can help :)

But isn't that cheating? ;)

Share this post


Link to post
emailking said:

I get no sound of any kind (either music or sound) on the level in question, map01. The other maps have sound/music as normal. Is this expected? The text file says there is music included. I'm using glboom+.

I have no sound/music related problems on the level with these versions:

glboom-plus2431.exe
glboom-plus2461.exe
glboom-plus2481.exe
glboom-plus2482.exe
glboom-plus2483.exe
glboom-plus2484.exe
glboom-plus2485.exe
glboom-plus2501.exe
glboom-plus2502.exe

So, I do not know.

Do you have all DLLs from prboom-plus-2.5.0.2-win32.zip such as libvorbis-0.dll, libvorbisfile-3.dll, etc in prboom+ dir? Music is in OGG format there.

Share this post


Link to post

Yes they're all there. I just went and got the latest test version and overwrote them all just to be sure. I tried prboom-plus too and it's the same thing. What's particularly confusing is that it's not just the music, it's all sound is just gone (like shooting & monster sounds too) when you're on the level. But as soon as I idclvev to map02, all sound is there, both music and other sounds.

Share this post


Link to post

I just did a separate unzipping of the official 2502 in a new directory. All I added were doom2.wad, longdays.wad, and my glboom+ config. Same issue. I even tried both 0 and 1 for process affinity mask. Same issue. :(

Share this post


Link to post

For your sound card or settings, there might be some conflict with the SDL mixer code that plays the OGG file that kills sound on your system. Do you get game sound if you use -nomusic? You could also try removing the OGG lump from the WAD, if that doesn't help.

Share this post


Link to post

If I do -nomusic I get neither music or game sound of any kind, and that includes on just the normal iwad with no pwad loaded. Is that the right behavior?

Share this post


Link to post

No, that's the behavior of -nosound. The -nomusic parameter should be allowing you to listen to the game sounds, without the music. That also seems to be specific to your system, as I was running the WAD with -nosound (while the included music isn't really bad in itself, I don't like music with vocals in DOOM) and it works fine in 2.5.0.2.

Share this post


Link to post

I will sound trite but...have you bothered upgrading your sound card's drivers? What kind is it, BTW?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0