need help with making doom youtube videos

I have in the past made some demos for youtube, but I would prefer if I could use my Mac to make them, since the PC that I have been using is kinda old and therefore I don't get the full 35 frames in some parts of some demos. Is there a good way to do this? I would prefer to use freeware/open source if possible.

Share this post


Link to post

You can export to a video with prboom-plus. I dunno the specifics, but one of the guys will tell you.

Share this post


Link to post

Yeah, natt wrote a cool system for capturing completely smooth videos from PrBoom+ even on crappy systems; you might need to play with some lag, but the output video should be perfect regardless, if that's what's important to you.

I only played around with the feature a little bit, but I think you just run with the -viddump parameter, more or less. The usage.txt file distributed with PrBoom+ should explain it all properly. It might be worth looking into.

Share this post


Link to post

Do you know when this feature was added? I looked through a list of changes and didn't find it.

Share this post


Link to post

From memory the default setting in the cfg is to format audio as ogg, which I don't think Youtube supports in uploads, so you'll need to change that to an mp3 encoder.

Share this post


Link to post
Ryback said:

audio as ogg, which I don't think Youtube supports in uploads

wut? ffmpeg doesn't support ogg vorbis decoding??

Share this post


Link to post

Try download PrBooom 2.5.1.2-test with also oggenc2, lame and X264 downloaded. Record it using PrBooom 2.5.1.2-test with command line, the recorded mkv demo can upload to youtube.

Share this post


Link to post

I downloaded the newest version of prboom plus (the file says created 12/25/2009), but when I use the viddump parameter, there is no file there or any evidence that a video was recorded.

Share this post


Link to post
xit-vono said:

I downloaded the newest version of prboom plus (the file says created 12/25/2009), but when I use the viddump parameter, there is no file there or any evidence that a video was recorded.


Have you downloaded all the other files needed for it to work?
(MKVToolNix, OggEnc, x264)

Share this post


Link to post

No, I haven't downloaded them. I suppose that they would be necessary, but it sounds really complicated to find all that and install them properly. Where can I find them?

Share this post


Link to post

Thanks a lot kimo. But there wasn't any dll's in the mkvtoolnix zip file, is there? I still extracted the files into the prboom+ folder and tried to make a video and it worked. But, while the video was being made, the demo was playing back very slowly, is that normal? The video played back fine though.

Share this post


Link to post
TimeOfDeath said:

Thanks a lot kimo. But there wasn't any dll's in the mkvtoolnix zip file, is there? I still extracted the files into the prboom+ folder and tried to make a video and it worked.

My bad, these dlls are only needed for the older version and they're packaged with the older version.
For the newest version that I linked to, you only need mkvmerge.exe

TimeOfDeath said:

But, while the video was being made, the demo was playing back very slowly, is that normal? The video played back fine though.

From usage.txt

The video and sound are encoded as the demo is played, so the process can be slow even on a fast computer. But, regardless of how fast the encoding goes, the resulting file can playback at full speed with perfect sound sync and no dropped frames. Note that while you can watch the demo as it records, you will not be able to hear any sound.


And btw it also says in usage.txt

Music recording will happen as long as you are not using the SDL or Portmidi music options.

If you want the music with fluidsynth to sound like SDL which uses Windows' General Midi, I've converted it to a soundfont and uploaded it here
Put gm.sf2 in PrBoom+ directory and change the snd_soundfont variable in the config file to "gm.sf2"

Share this post


Link to post
xit-vono said:

I downloaded the newest version of prboom plus (the file says created 12/25/2009)

You downloaded 2.5.0.6 from 2009 instead of 2.5.1.3, right?

Share this post


Link to post

I intended to get the most recent version of prboom plus. I did a google search for prboom plus, then followed the link and went from there. The files say that they were created in 2009, but the history txt file goes up to 2.5.1.2

Share this post


Link to post

Thanks, but I think everything was OK already. I don't know why the date is so far back on the files. I got the movie recorded and then checked, so now I will post it.

Share this post


Link to post
xit-vono said:

Thanks, but I think everything was OK already. I don't know why the date is so far back on the files. I got the movie recorded and then checked, so now I will post it.

2512 is broken, i even removed it from sf.net.

Share this post


Link to post

I tried to post the video on Youtube, but I think it may not be a supported format. Any suggestions? Playing the file back with windows media player works fine.

Share this post


Link to post

What are the video specs? Container, video, audio, resolution etc.

Share this post


Link to post

Youtubing my 30nm2939 run ?

I was originally planning to redo this run some years ago. Had some
decent attempts I remember, but never had any luck when it did matter the most. Or I was just getting too old and slow, who knows :)

Anyhow ..there wont be any more recordings from me now ..so I was wondering if someone was up for the challange for youtubing it ?

Would be great!...

Share this post


Link to post

Youtube does accept .mkv files. In fact, when I didn't have VLC installed I uploaded a demo I -viddump'd just so I could watch it lol.

Share this post


Link to post

Hmmm, I tried to upload my mkv the second time and it worked. We'll see if there are any problems in the future. Perhaps Youtube changed the way they process videos or something, or else maybe there was a glitch earlier.

Share this post


Link to post

Haha my recordings always looked crappy. I used FRAPS and I would need to string several videos together to make a complete movie run. I bet it's easier nowadays.

Case in point:

Share this post


Link to post

...always did wonder why I didnt quit after map06 ..lol :)

Thanks for this Ryback :)

Share this post


Link to post
skogsto09 said:

...always did wonder why I didnt quit after map06 ..lol :)


Because gods don't quit. :P

Share this post


Link to post

Hi, as you can see, I have been using this feature. I uploaded es08 to youtube, but there are some video problems that I didn't notice right away. I checked the viddump file and it has those problems too. Also, I tried converting pt08 to video, and that one has video issues too. Anyone have an idea what causes these?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now